Hitmenu not showing up

First of all, I know there are many threads like this, but they dont fix my problem.

  1. I set hitmenu to false in disabled_defaults.lua
  2. I added

DarkRP.addHitmanTeam(TEAM_HITMAN)
DarkRP.addHitmanTeam(TEAM_ASSASSIN)

to jobs.lua and jobrelated.lua
3) I checked syntax and everything is just fine

Please help. Thanks in advance.

Nobody? I’m desperate.

Maybe try, DarkRP.addHitmanTeam(TEAM_HITMAN, TEAM_ASSASSIN)
go back and make sure they are spelt correctly

make sure in disabled_defaults.lua that the “hitmenu” is set to ‘false’ and not 'true’

if that doesn’t work, then I recommend setting the mobbos in disabled_defaults.lua to ‘true’ and make your own ‘new’ mobboss job, do not rely on the default one.

set this to ‘true’, for it to disable

EDIT: do not add ‘DarkRP.addHitmanTeam’ in jobrelated.lua
just leave it in jobs.lua under this

I did everything you said but it´s still not working.

Nobody? I really need to fix this.

Post your job file and your disable_default and I will have a look.

jobs.lua



TEAM_HITMAN = DarkRP.createJob("Hitman", {
    color = Color(0, 0, 0, 255),
    model = "models/player/agent_47.mdl",
    description = [[

    You are the go-to-man for all problems. You ruthlessly kill your targets. 

    Make sure to do your job as smooth and secret as possible, you don't want to get caught.

    You cannot raid.

    You cannot base.

    You cannot mug.

    You can own illegal entities.

    You cannot kidnap.]],

    weapons = {},
    command = "hitman",
    category = "Criminals",
    max = 3,
    salary = 50,
    admin = 0,
    vote = false,
    hasLicense = false,
})

--[[---------------------------------------------------------------------------
Jobs that are hitmen (enables the hitman menu)
---------------------------------------------------------------------------]]
DarkRP.addHitmanTeam(TEAM_HITMAN)


disabled_defaults.lua



DarkRP.disabledDefaults["modules"] = {
	["afk"]              = true,
	["chatsounds"]       = true,
	["events"]           = false,
	["fpp"]              = true,
	["f1menu"]           = true,
	["f4menu"]           = true,
	["hitmenu"]          = false,
	["hud"]              = true,
	["hungermod"]        = true,
	["playerscale"]      = false,
	["sleep"]            = true,
	["fadmin"]           = true,
}

--[[---------------------------------------------------------------------------
Jobs that are hitmen
set to true to disable
---------------------------------------------------------------------------]]
DarkRP.disabledDefaults["hitmen"] = {
	["mobboss"] = true,
}