HL2 Bug....

Hello, I have a bug with garrys mod and the bug is, Everytime i spawn a hl2 prop it will have some black stuff. Everytime i use my physgun/Toolgun its black. Everytime i use a css weapon its black. Can you guys tell me why its being like this? I reinstalled garrys mod, But still have same error. I have hl2. But don’t seem to be the problem. Please tell me whats going on! EVEN PLAYER MODELS ARE BLACK!

Pics:
http://img705.imageshack.us/img705/884/gmconstruct0002x.th.jpghttp://img190.imageshack.us/img190/2714/gmconstruct0003e.th.jpghttp://img293.imageshack.us/img293/5755/gmconstruct0005i.th.jpghttp://img594.imageshack.us/img594/5825/gmconstruct0006f.th.jpghttp://img121.imageshack.us/img121/8831/gmconstruct0000bs.th.jpghttp://img191.imageshack.us/img191/4191/gmconstruct0001r.th.jpg

** PROBLEM SLOVED!!! Lets give a thank you to, Alexis-nyan for this code! **


 -dxlevel 81

Update your video card drivers?

Re-install HL2 and GMOD?

Yes i did.

[editline]14th November 2010[/editline]

Gave it a try not the problem.

Delete the skins folder?

Yes, I used to have the exact same problem, although I only had it with a gamemode that I was fixing.
All I had to do was to comment out some lines in the gamemode that was causing this (it had to do with lighting), and the problem was solved.

But, since you seem to be having this with sandbox, I doubt that this is your problem… If reinstalling GMod didn’t solve the issue, then it must be a source engine problem.

Doesn’t seem like a MAJOR problem, it’s not affecting your gameplay is it?

I’d have suggested reinstalling your GMod but if you’ve already done that it may be a problem with your video card.

I figured out what the problem is. DirectX9 apparently causes this.

I run DirectX9, and i dont have it.

Also, OP- Do you have and ATI video-card?

Yes.

[editline]14th November 2010[/editline]

Its is a big deal. I don’t want to see black stuff.

goto CCC and disable the AA and stuff. (or check the box “Use Application settings”

I just did that to fix my BFBC2

Were is CCC?

You should have it installed but if you dont here you go

It should be in your programs list

Didn’t work… And this is really annoying! Not even my wire work.

As looking in my console all the time i keep seeing this weird error. I think this might cause the problem. Can someone tell me how to fix it?


Material models/spawn_effect2 does not support vertex format used by the mesh (maybe missing fields or mismatched vertex compression?), mesh will not be rendered. Grab a programmer!
P

This is a problem that Garry needs to fix.

So what? I have to wait for garry to fix the bug? Or i have to massage him?

I’m sure a lot of people have complained to him about it.

So what am i post to do then?

I have the same exact problem, im on a crappy dell inspiron 1501 with a 128mb ati graphic card, and 2gb of ram and iv been forced to run this in dx81, although i restored my gmod a couple of weeks ago when everything was going ok, but now this. So i guess garry needs to fix this because i only having this problem with gmod.