Hl2.exe Application Error, Fixes and Information.

My Computer Stats;

Microsoft Windows XP Professional Service Pack 3
AMD Athlon 64 X2 Dual Core Processor 3800+ 2.01GHz, 1GB of RAM
NVIDIA GeForce 9500 GT graphics card
25Gb Free Space

Introduction; YOU DO NOT HAVE TO READ ALL THE TEXT, YOU CAN SKIM THROUGH IT AND STILL BENIFIT. THE LENGTH IS ONLY FOR DETAIL AND UNDERSTANDING. The main reason I have created this thread, is because we have thousands of threads on this issue, with little help if any at all. Also I have a slightly different Hl2.exe Application Error then all the threads seem to share. My error doesn’t pop up on starting the game, it occurs once I have just connected to a server and SPAWNED. The game instant-freezes and after 5 seconds or so Hl2.exe Application Error comes up.

Now down to business.

Below is a link to a picture of the Hl2.exe Application Error. (NOTE it says Gmod9, this error occurs in a range of games for many people such as; Gmod 9, Gmod 10, Team Fortress 2, Half Life 2, Counterstrike and probably more. Despite this, it’s still the same error.)

http://img145.imageshack.us/img145/4919/gmoderrorxb6.png

Some fixes I have found on the internet that didn’t help me, but have helped some others in need.

  • Open up steam games list, right click on Garry’ s Mod and select Properties. Go to the Local Files Tab and click the button that says; Delete Local Game Content… NOW this wont delete the whole game, just a bunch of files. The game will appear in the uninstalled games list, so right click on it and select Install. It will only have roughly 100mb to install. What this does is replaces some files you just removed that could be the source of the problem.

  • Another option you have is to go into steam games list, right click on Garry’s Mod and select Properties. Go to the Local Files Tab and this time select the button that says; Verify Integrity Of Game Cache… I’m not going to pretend I know how this works, and it doesn’t matter as long as it is an option to fix the problem at hand. It will update your files or something, adding any you may be missing. Some claim it works, others like me find no solution, but it doesn’t take long so consider it as an option.

  • You can also go into steam games list, right click on Garry’s Mod and select Properties again. Under the first tab that pops up, which is General, click Set Launch Options. In this type; -dxlevel 8
    This may work, if not don’t worry it was worth a shot. If it does not work you may want to go back to that and remove the command you put in incase it causes you any problems (although I don’t think it should)

  • Delete all your addons and reinstall them, or at least only reinstall the ones you need such as PHX3, Wiremod, Wiremod Addons, Smartsnap, Adv Dupe, Conna’s Tools, and possibly GMOW. If any of the addons were broken and causing you issues, this might help fix it.

  • You could try deleting your LUA files and reinstalling them via joining servers, or online.

  • Final and LAST resort… The one nobody wants to do, you could try REINSTALLING GMOD COMPLETELY. Now before you blame me for telling you to do this, it might not work but it’s worth a shot if gmod isn’t working anyway, any chance to get it working is worth it in the end. THERE IS NO GARUNTEE IT WILL WORK THOUGH.

So hopefully I have helped you guys slightly if at all… At least more then the thousands of forums of complaints and no solutions.

Try reinstalling your hard drive. Tell us what it says.

Just recently (roughly 2 weeks ago) I had my father completely format my hard drives and reinstall windows, I installed all my games and we took an Image. I am not confident enough with my computer skills at the low level it is at to Reinstall my hard drive if my understanding of the task is correct. Why would I want to do that anyhow?

He’s being an idiot, so ignore the dunce.

Does anybody know the cause of the problem? Is it a new patch or a missing / corrupt file or what?

[editline]05:48AM[/editline]

UPDATE; I found that the error only occurs when I join some RP servers, I tried an Icannt Essentials Build Server and I was able to connect and play, with many glitches. I am not sure if it was a one time glitch or if my game is flawed, but I’ve restarted my computer and am about to try it again and see if I can connect. Perhaps the RP Servers aren’t up to date? Does anybody think this could be the cause of my hl2.exe application error?