HL2.exe error

So I brought Gmod 10 today.

every time I run it it will show the loading screen and loading bar, once the loading is done the screen just goes black. I open Task Manager and see that it’s not responding so I close it and then the HL2.exe error pops up… any ideas on a fix?

I’m running Windows Vista Home Premium.

Say your computer specs so we can help.

Processor, how much Memory RAM, Video Card, is it on-board or not?

sorted it, dw :stuck_out_tongue:

This happend to me about 3 days ago, I figured out I had an lua file that was doing that. I tried to delete it with no luck, so what I did was backup all my addons delete all the gmod local content plus the folders in steamapps then when I re-installed I put each addon in 2 by 2 until I had the problem again and then deleted the one doing it. Then it worked once again. Here is my thread- http://www.facepunch.com/showthread.php?t=858505

-dxlevel 80 -console -windowed -32bit

I just added that to the startup and it started working smoothly