"hl2.exe has stopped responding" after joining multiplayer server

When joining a specific RP server running rp_evocity_v2d, I get a CTD after “Sending Client Info” with the usual hl2.exe error.
Haven’t tried other servers, so I’m not sure if it happens to all of them.

Specs:
AMD Radeon HD 6850
AMD Phenom II x4 955
4GB RAM
Windows 7 64-bit

I jave tried:
Starting Gmod with +r_hunkalloclightmaps 0
Setting shader quality to low
Playing evocity_v2d in singleplayer first (which works, but breaks keypads)
Reinstalling Gmod (which works once)
Verifying chache files
Defragging cache files
Updating graphics drivers

Crash dump:
http://dumps.garrysmod.com/?view=4259717970

Eh.
Have you tried to just join the server and instead of clicking it all the time go and do something else for it to load?

Try to delete your cache folder and lua folder, usually works. But after your delete those folders make sure you join a singleplayer before you go and try to join servers again. Also make sure that you have the gamemode for what ever the server is using sometimes the server doesnt provide the files you need. I will think of some more things.

I’m having the EXACT same issue UnknownDude.
Worked perfectly last night, wake up this morning. Unable to join a certain server.

Testing your method now Anthn0x.

EDIT: WORKED :slight_smile:

It works if I tune down the video setting a notch. I would like to be able to play with full settings, though.
I guess that the latest AMD drivers are causing the problem, since I haven’t had this problem before.
But anyway, it is temporarily fixed.