''Hl2.exe has stopped working'' problem

Hello all, i’ve been knowing that forum for i while, but never registered!

Well. I’ve been playing gmod for 3 or 4 years but recently got a New laptop (Satellite P200-rt2 on Windows seven ultimate)

And every time i try to play, it works perfectly fine until i shoot something (NPC or player). Then it goes black and says ‘‘hl2.exe has stopped working’’.

I looked in my gmod folder and a weird thing like that appeared : hl2_4104_crash_2010_3_10T3_15_31C0.

I’ve tried ALL tips i could find but nothing worked… If someone can help me it would be great!

PlamZ

Your running on a Intel GMA.
Upgrade the Laptop, there is nothing you can do.

See that 945 in this link http://www.ncix.com/products/index.php?sku=25703&vpn=PSPB0C-RT208C&manufacture=Toshiba#Specifications
That’s whats stopping you, and the fact it’s a Intel GMA.

Oh… Shit… Really nothing? because i can’t afford to upgrade it…

Absolutely. Nothing
Unless you like Console, and want to constantly remain on Single player for the rest of your life.

Damn… Thanks men… Is that only on GMod or other Hl2 games?

ALL orange box games.

Hl2 EP1 and CSS are fine.

Nooooooooooes T__T’! I hate CSS. But i love portal and tf2…

Well, thanks man, i’ll stop searching :P!

Have a good night!

This might work for you:
1:Right click Garry’s mod on your steam games list
2:click properties then set launch options
3: then type -dxlevel 90
Then play Garry’s mod :slight_smile:

What are you talking about? There’s plenty of options. OP, either go into the launch properties of Garry’s Mod and plug in -dxlevel 80, or you can try -autoupdate, as it puts the game into the best settings.

Don’t tell him lies. You can’t upgrade laptops easily since everything is sautered into it

I think he basically meant get a new one.

Although laptops are upgradeable.

I said it wasn’t easy

your an idiot, 10% of laptops gpus can be upgraded. So don’t you tell lies.

I have a solution. Right click gmod>Launch Options> type “dxlevel 81” (without quotes)

[editline]02:37AM[/editline]

This will not work because it is already running at 90 level because his card will not run anything above 10.

He needs to set it to -dxlevel 80 or dxlevel 81

We’ll i’m trying right now :D! Thanks guys -!

[editline]08:02PM[/editline]

None of em worked =s

Anybody has an idea =s?

okay, temporary fix.
pull up the console, type these two commands while in single player.
Sv_cheats 1 and enter
r_drawparticles 0 and enter
this will allow to blood, explode, set on fire to your hearts content, until you turn off the cheats, change maps, or crash it.

Oh! Is there a way to patch that ‘‘drawparticles’’ forever :o?

Update your driver like I did, It will work fine!

No.