hl2.exe has stopped working

Whenever I start Garrysmod or TF2 it gets to the load screen and the suddenly stops, giving me a message saying that hl2.exe has stopped working. I already tried updating my cards and I deleted Garrysmod and re-downloaded it. HELP!

Gpu?

I have this same exact problem, but GMod has worked on my computer many times before. Any suggestions, fellas?

try deleting your latest addon. that file maybe corrupting your gmod’s files

I (I doubt the OP will come back after a bump like that) have actually deleted everything about GMod and reinstalled it. I think it must be a problem with my HL2 or something, yet that runs just fine. Should I just redownload that too?

I’m having an error like this too. I click start GMod in steam, it pops up the windows saying it’s starting, it closes, a second later, BAM! It says hl2.exe has encountered an error and needs to close.

It was running perfect earlier today, I deleted the only addons I downloaded today, I just reinstalled yesterday, and the only server I joined was my organization’s server, which I’ve played on before with no problems.