HL2.exe has stopped working...

Hi all,

This error just started today randomly. I did not install anything or change anything. I did try to join a PERP RP server last night and it was doing a really strange exit every time I tried to join…? Maybe that’s what has caused this…? Anyways, I was able to play GMOD perfectly fine previously before today, but now I’m having a really strange problem. I can join a server and see everyone move around, etc., but as SOON as I move around, my game starts to stutter a bit and then the error message “HL2.exe has stopped working” comes up… The same thing happens in single player. I’ve tried reinstalling graphic drivers, reinstalling GMOD, but nothing has worked.

Here are my system specs:

Windows 7 Ultimate 32 Bit
ATI Radeon HD 4870
Intel E5200
4GB of RAM

I can run CS:S fine, but upon exiting I noticed that I get the “HL2.exe has stopped working”, but this is only upon exiting…it doesn’t crash like GMOD. Does anyone have any idea on what’s going on here?

Thanks

[editline]02:08AM[/editline]

Ok, I went into my control options and set them to default and it seems to have fixed the problem…? wtf?

Same problem i am having what control options Gmods?

In options, controls, set them to default.