"hl2.exe has stopped working"

This is displayed at the loading screen, approximately 20 seconds after launching Garrys Mod.
Specs:
Windows Vista
Intel® Core™2 Duo CPU, T6400 @ 2.00GHz
3 GB RAM

Clear our your dua cache, your modules, and your addons and try again.

That didn’t work. I also have no addons folder…could this be a problem?

i think new gmod does not come with an addons folder, just create one

I have:
Windows Vista
Intel® Celeron® CPU 900 @2.20 GHz 2.19 GHz
2.00 GB RAM
32-bit operating system…

And I have the same error… “hl2.exe has stopped working” even though I just got it two days ago… Same with Garry’s Mod…

The only game that has this problem is Garrys Mod; CS:S, HL2, Portal, TF2 all work fine.

It should also probably be known that I just downloaded Garrys Mod.

I’m getting the same error with all my addons. I have also removed them and I still receive the same error. Is this because of the recent source update?

I too am having the exact same problem after just downloading it and I only have this problem with Gmod too.

Hm…
Try the following:
-Update your drivers
-Make sure your graphics card can handle the game. You did not mention your graphics card.
-Try right-clic in gmod (in steam), propiertes, set launch options, and write this:


-dxlevel 81 -console

Or maybe:


-dxlevel 80 -console

thanks that I think that first code did the trick

That worked, however I have a new problem. I can’t exit out of the game and launch it again; it says I already have one instance of the game running.

Kill it in task manager.

It does not appear in task manager. :
Do you mean kill Steam or Gmod?

to to task manager click the processes tap and end task for hl2.exe

Thanks for the code! That made it work! :smiley: