HL2 rebel models are overridden

So, a few months back, I installed an addon, the TnB megapack, it’s like a roleplay thing, using legacy addon thing. This addon replaces the default HL2 rebel models, Group03 and Group03m. Now, a while ago, I removed it, but the models are still skinned as they were in the addon.

I have tried reinstalling GMod, but it did not fix.

I also tried the verify inegrity of game cache, and tried removing the files manually. It worked until I restarted the game.

Please, help me!

This is likely a minor issue, but it means alot to me, since i am pretty much a perfectionist.

Delete (and backup if you wish) the download, materials, and models folders in /garrysmod/garrysmod/

Check if there is anything left in in \garrysmod\materials\models\humans or garrysmod\addons\materials\models\humans. If not, check to see if you have any workshop mods enabled.

Tried deleting, didn’t work.
Currently on the lookout for any conflicting Addons.

I tried looking, couldn’t find anything.
Are there any other posibilities?

Sorry for double post.

Have you tried removing all legacy addons and disabling all workshop addons all together?