HLMV cannot find the .vmt AGAIN

This stupid compiler or whatever still wont compile with textures and yes the vmt and vtf is in the same file.

.vmt


"VertexLitGeneric"
{
	"$basetexture" "models/ror/thatguy/singleplayer/breadguy"
	"$normalmap" "models/ror/thatguy/singleplayer/breadguy_normal"
	"$translucent" 1
	"$model" "1"
}

.qc


$modelname	“ror\singleplayer\guy\samthetrucker.mdl”
$body mybody	“DrawCall_1155.smd”
$surfaceprop	flesh
$staticprop
$cdmaterials	“models/ror/thatguy/singleplayer/breadguy”
$sequence idle	“DrawCall_1155.smd” 
$collisionmodel “DrawCall_1155.smd”
{
$mass 15
}

the .bat compiler (the GUIStudioMDL will not work)


"C:\Program Files (x86)\Steam\steamapps\common\Counter-Strike Source\bin\studiomdl.exe" -game "C:\Program Files (x86)\Steam\steamapps\common\Counter-Strike Source\cstrike" compiletheguy.qc
pause

and the .mdl


IDST0   À‰¬ror\singleplayer\guy\samthetrucker.mdl                          ¼              ó濇®Ø¾¼w>eÀ}«q¿ÞÍ“½¾ƒ?    –	7?                              ˜      p     p     €     ô             è     (        ,     Ð      p      Ð  Ð      t      t      t      t      t      t  X  0          t    pA       è      0      è      |                      t          ˜          0              ™                                                                                                                                                                                                                                          Æ  ÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿÿ                          €?             €; €; €;mI7mI7mI7  €?       €   €      €?       €          €?   €                               À                                     ú             €üÿÿò    ðA                                           p                                                       ÿ   üÿÿ„  <      ÿÿÿÿ        Ô   eÀ}«q¿ÞÍ“½¾ƒ?    –	7?   Ø             ÿÿÿÿÿÿÿÿ                    ÍÌL>ÍÌL>                                        Ô   Ô           Ø   Ü                                         €?    •           DrawCall_1155.smd                                                          ”   ?	                        ØHº¨¼                                    lÿÿÿ?	                                      Laø?	  ?	  ?	  ?	  ?	  ?	  ?	  ?	                                  œ               ”íb                                                   ror\singleplayer\guy\samthetrucker.mdl flesh static_prop default @idle idle mybody material_15 models\ror	hatguy\singleplayer\breadguy\   

And I keep removing the \ where models\ror hatguy\singleplayer\breadguy\ is and it does not work no matter what I do.

$cdmaterials isn’t used the same way $basetexture is. Essentially the $cdmaterials command tells your model what path(s) to look for to find the VMTs listed in the SMD file. The $basetexture command is what tells the VMT where to find the location of the VTF file, as well as what the name of the VTF file to use is.

ex:


"$basetexture" "path1/path2/path3/materialname"


$cdmaterials "path1/path2/path3/"

Now it’s saying that it is a bad command.

It should be exactly the same as it was. The only change necessary was to either remove breadguy from the end of the material path or to add on the material name to the end of the $basetexture depending on how you have it all set up.

Still not working it still says that “$basetexture” is a bad command.

[editline]24th September 2013[/editline]

I was talking about the $basetexture command in your VMT file, not putting it in the QC file.

By the looks of it, your model is looking for “material_15”, while I’m assuming your VMT is called breadguy. Correcting this should fix your issue, provided there’s not other stuff causing it as well.

This does not work I’m confused and getting pissed off.

You removed the models folder from $cdmaterials in your QC file, now.

Nothing is working.

[editline]24th September 2013[/editline]

I’m doing everything right and this piece of shit will not do anything right.

You kept changing the path a moment ago. If you can, just take a screenshot of where your VTF/VMT files are and I’ll write the paths for you.

Here is everything in this .zip file http://www.mediafire.com/?hrku3ap3uj8woyh

Here’s the same thing back. All I really did was rewrite the QC a bit. It worked for me; it should be fine as long as the materials and such are in the right place.

It didn’t work for me.

It worked for me. The only thing I can think of is that you’re putting the material in the wrong path. Make sure both VTF files and the VMT file are in:


C:\Program Files (x86)\Steam\steamapps\common\Counter-Strike Source\cstrike\material\models\ror	hatguy\singleplayer

They are.

WAIT IT WORKS’
THANK YOU
Stupid HLMV doesn’t work after the steam-pipe update but thanks.

You need to launch HLMV with the batch commands. Also from what I can see, your model thinks the VMT is called material_15 so I’m guessing you messed your SMD on export a bit as well.

B - But … But he fixed it.