Home hosted dedicated server problem

So basically I set everything up for the portfowarding and the server files. I don’t have addons yet, but you know I’ll do that last. I can’t launch the server from the start.bat file, but I can from the srcds.exe file. When I launch it from the srcds.exe, I can’t find it anywhere in the server lists, but I can use the console command “connect <ip>” and I am able to connect. With the start.bat file, I try connecting but it never works. Yes, I did port forward with all the ports I could find for gmod, yes I did port forward my ip and such. I also have some other issues as well.

I can’t change the gamemode (I’m trying to open a deathrun server)

Server says “missing map <map name>, disconnecting” if it is on a map except gm_construct (yes I have the map installed)

I can’t use the authkey for people to download the addons, sadly.

That basically concludes everything. (P.S, I own an apple router, so portfowarding is a lot different, but I know how to do it.)

Don’t host from home, you’re just going to end up getting DDosed anyways.

Read this for adding workshop download for the map: http://wiki.garrysmod.com/page/Workshop_for_Dedicated_Servers

Im broke as hell so I don’t have an option. But do you know a fix for not finding the server? Here is my config for start.bat


@echo off
cls
echo Protecting srcds from crashes...
echo If you want to close srcds and this script, close the srcds window and type Y depending on your language followed by Enter.
title srcds.com Watchdog
:srcds
echo (%time%) srcds started.
start /wait srcds.exe -console -game garrysmod +deathrun_helix_b8 +maxplayers 6 +gamemode deathrun +host_workshop_collection 404098362 -authkey NOT TELLING
echo (%time%) WARNING: srcds closed or crashed, restarting.
goto srcds

Here is a simplier code for startup.bat or whatever:

It starts up the separate window the closes out of MS-DOS (command prompt)

[editline]8th March 2015[/editline]

I spelled authkey wrong, stupid autocorrect.

Still unable to connect through start.bat .-. BUT: I can use the srcds.exe, BUT: I still can’t get playermodels/addons on BUT: I can use maps :smiley:

[editline]8th March 2015[/editline]

I also can’t find it on the server lists, sadly. It’s in the sandbox gamemode, yet I still can’t find it there.

EDIT: I can see it in my history, but thats because I connected to it with “connect <ip>”