HOW CAN I LIMIT MY RUST FPS

Hey guys I am having trouble playing rust because my computer is overheating while playing. I play on lowest graphics and normally at 100+ fps - It seems my computer is running harder than it needs to as 60 fps is apparently the maximum the human eye can detect… How can I limit my fps so that my computer can chill out while playing. I have got Vsync enabled on Nvidia control panel and tried a software called nvidia inspector but they seem to have no effect on rust.

Please leave ideas to help me and others out. <3 Game is Epic, let me play it!


(User was banned for this post ("all caps thread title" - postal))

I think it’s a bug with the game right now. It makes your GPU run at 99%… They probably know about this already. Not much you can do :confused:

Thanks for the time you took to help me out :smiley:

You’re welcome.