How can I turn off the collision smoke effects?

When you bang a prop against the floor it makes a smoke effect, is there any way I can turn it off, it get’s quite annoying when I’m building?

I don’t think so.

I’m not sure, but it gets annoying because adminges can ragdoll you and slam you against the wall and there is so much smoke you crash.

I fucking hate this so much. What you could do is find the smoke effect and replace it with just a alpha texture so that when it does happen you can’t see anything,

Why not just turn off r_drawparticles 0
with Sv cheats enabled, alot more easier.
And vexx why so angry.

Because it lags my game so bad.