How do i compiled file?

I’m trying to compile a file from a .SMD, but i get this error message in GUIStudioMDL:

“Invalid gameID found while creating command line”

first question is:
was this error due to (A) my .QC file, or (B) my configuration settings?

if (A), what do i need to fix?

$modelname garrysmod/garrysmod/addons/lambo_rev/Lamborghini_Reventon.mdl
$scale 1.0
$body “Lamborghini_Reventon” Lamborghini_Reventon.smd
$sequence idle “Lamborghini_Reventon_smd” fps 30 ACT_IDLE 1
$surfaceprop “metal”
$cdmaterials “garrysmod/garrysmod/addons/lambo_rev/”
$collisionmodel “Lamborghini_Reventon.smd”
{
$concave
$mass 1200
}

if (B), i configured my settings for the orange box, do i need to configure them for ep1, or is there a completely different folder i need to look for in /source SDK ?

its the title, isn’t it?

Go to your garrysmod/garrysmod folder find the txt file called “gameinfo.txt” open it and put a minus sign in front of the “211” so it’s now “-211” and save, problem solved.

However you will have to do this everytime after running Gmod as it regenerates the file as new (without the changes).

Alternatively someone made a fixed compiler that you don’t have to change the thing to make it work but I can’t remember where it was and i’m not explain about hexing right now so you can do it yourself (but if you want to try, open the studiocompiler.exe with a hex editor and alter the line that says “toolsappid” to “foolsappid” or some such so it doesn’t look for it).

odd, that fixed the issue with the command line, but now studiomdl.exe is crashing after

i put studiomdl.exe in that folder, should i put it somewhere else?

If compiling for orange box, just create a batch file (.bat) and put this in it.


"%sourcesdk%/bin/orangebox/bin/studiomdl" %1
pause

studiomdl.exe needs to know what game to compile it for so run source sdk once and in the dropdowns select 2007 engine and Episode Two. Now drag drop your .qc onto the newly created batch file.

hm, it says

should i write my QC file differently?

Yes


$modelname "lambo_rev/Lamborghini_Reventon.mdl"
$scale 1.0
$body studio Lamborghini_Reventon.smd
$cdmaterials "lambo_rev/"

$sequence idle "Lamborghini_Reventon.smd" fps 30 ACT_IDLE 1

$surfaceprop "metal"

$collisionmodel "Lamborghini_Reventon.smd" {
$concave
$mass 100
}

Don’t need all that addon pathways stuff and if your running studiomdl.exe from a bat file you will need to make the “lambo_rev” folder in the models folder of whatever game your compiling to.

Edit: Also fixed an error on the sequence smd path name. And you don’t need a mass of 1200 it probberly wouldn’t be able to be picked up.

You also didn’t put the file directory.

Put this in your .qc at the top. ( change the directory to where ever it is )
[lua]$cd “C:\Documents and Settings\Owner\My Documents\lambo_rev”[/lua]

mkay, that worked!.. sorta. i need to go back and tweek the .SMD file before i release it though. thanks guys

np. Glad it helped ^^

I think I might have screwed up my directory settings in guistudiomdl. I got it to work once, then I closed it, and it won’t work again now. Can someone please help me get it working again? I can’t release my custom Crash Twinsanity ragdoll until I get this fixed.

Just use studiomdl instead.