How do I export models from 3ds max 2013 to CS:GO?

I’ve tried to export this static prop through GUIStudioMDL, WallWorm, and straight through command line, they all seem to spit out the same error.


Created command line: "<studioMDL path>" -game "[STEAMDIR]\common\Counter-Strike Global Offensive\csgo" -nop4 -nox360 "[STEAMDIR]\sourcesdk\modelsrc\yadda\windowframe_001.qc"

MountFilesystem( 731 ) failed:  SteamMountFilesystem(7636,731,0x16a4f570=,0x16a4f460) failed with error 5: No CS online with App 731 Ver 0

I decided to try to export through CS:S, and try to copy them manually, but I get a different error.


MountAppFilesystem() failed:  SteamMountAppFilesystem(4294967295,4294967295,0x16aafb14) failed with error 4: Bad launch configuration

Things I have done:

  • Restarted steam
  • Refreshed SDK Content
  • Verified integrity of game cache on both cs:s and cs:go
  • Ran both games

I Use StudioCompiler. and I Export the model for CS:S. and put it into CSGO.

Every time I try to compile via StudioCompiler it crashes.

Have you had SDK running whilst compiling?

I think I got it figured out but the process was a bit confusing. I went to Source SDK to try and open ModelViewer but it said it could not find game_sounds_manifest.txt (Even though it was there).

I edited the game configuration from SDK Tools and made sure it was pointing to the “common\Counter Strike: Source” location. Then I edited gameinfo.txt so that it read:


SteamAppId 240
ToolsAppId 211

After doing this I could open modelviewer and then compile a model via studiocompiler. As a consequence of this I can’t use CS:S Hammer, but that’s ok since I want to model for CS:GO anyway.

Now I have to figure out why my materials appear black.

Why doesn’t stuff like this work out of the box? Why am I subject to a scavenger hunt when it comes to this? So frustrating.