How do I get Models from SMD to MDl Again?

What do I use to get models converted back to their original MDL format after I edit them in 3DS?

You use a MDL Decompiler
Google Cannonfodder’s website

I have the decompiler, do I just decompile it the same way I did the first time it and it will just go back?

[editline]09:52PM[/editline]

My file is already in SMD. I tried using the MDL Decompiler but it wont put it back to an MDL.

StudioMDL
Sorry rate this bad reading.

I installed MDL Studio, why would I want to compile the QC? I want to compile my exported SMD file of the model I had just edited.

Because that qc file contains all of the information for the model to even work.

Let’s say I did compile the qc file? I never edited the qc file, what use would compiling the qc file be? It’s the same qc file as it always was before I edited the model. I get the qc file compiled and then what? I still have my other model in SMD format that I need converted to MDL! The QC file just sits in it’s qcness being of no use to me. Ya see, I need my SMD converted, not my QC, it’s the SMD that I exported from 3ds, all the edits and changes are on my SMD, not my QC. I just want to know why i need this QC converted, what does it do? Why Shot, why do I need to convert the QC?

http://www.facepunch.com/fp/emoot/ughh.gif

http://developer.valvesoftware.com/wiki/Qc

Without that qc file, you don’t have a model.
Just edit it to what you want your new model’s name to be, and do whatever else you want.

I have the QC file. It’s a QC file, alright, there it is. Right now the QC file is having a great time in it’s current format, alright. Fuck the QC right now, I have an SMD that is just begging to be converted to an MDL, he wants to be an MDL so damned bad he’s practically begging for it.

What did I just fucking tell you. Edit your qc file and name your new model and file path, texture path, etc.
then compile it with GUIStudioMDL, If you can’t get these simple instructions then I’m not helping you.

Sounds like a plan, except, shot, look, SHot. I’m having a problem, ya see, I keep getting this awesome error when trying to adjust the path for #$%^ing Orange BOX Friggin capabilities, friggin inside the Bin. Meaning I can’t adjust the settings in my editor to match the Orange BOX bin! “Game Config Txt file cannot be found” It’s telling me. There is nothing in the readme about a plan C, nothin’ what use is an editor that can’t do what its supposed to?

Did you even set up the tools path…

Yes an no. I tried to set up the tools path and --=BAM!=-- a fucking error popped up and burned a hole in my flat screen. I do everything i’m told, I tried to do it, I tried, Shot! You should know how much of a pain these programs are.

I set it up with no problems, I’m not sure why you’re having such a difficult time with it.

Don’t play me, SHot. i told you exactly why I’m having a difficult time and you haven’t offered a solution. I appreciate the help but what do I do? Also, I moved my steam to a different Drive.

OK, everybody CHILL THE FUCK OUT.

Kurit, what you need to do is compile the model. The two parts needed to compile it are the SMD and the QC. The SMD contains data on the shape, the rigging and such; the QC contains info on where the model goes and what materials it uses. The QC also tells the compiler which SMD files to use.

That’s why, when everybody was telling you to compile the QC, they were right (although they could have explained better). The SMD on it’s own is useless; the QC file is what the compiler reads first, hence “compiling the QC file”.

As to getting through the errors, I find the easiest method for me is a simple batch file. Just copy/paste this into a file and rename it “compile.bat”



"%sourcesdk%/bin/orangebox/bin/studiomdl" -game "C:\Steam\steamapps\bob42\garrysmod\garrysmod" -nop4 ./model.qc
pause

Change the “model.qc” to the name of the QC, and double-click the file.

That may not be the easiest or most elegant solution, but that’s what I use.

That was pretty helpful. So you want me to open notepad. What do you mean by change to model.qc, Change what to Model Qc?

In that text file, the “./model.qc” is telling the compiler to open a file “model.qc”. Since that probably isn’t the name of the QC file you have, just change that part of the batch file to the actual name, e.g. if the QC file was “stripper.qc”, the batch file would have the line end with “./stripper.qc”

What’s telling me to open a text file? I opened the Qc in notepad, what part do I change to an actual name? I honestly don’t see the name of it, I see a path name at the top of the listed notepad texts. I’m also still having problems with GUIStudio, it is still not working. “Game config Texts cannot be found” it’s telling me. GUIstudio isn’t working and I can’t figure out what line you’re telling me to change, I can’t find the text line that I’m supposed to edit.

OK, I’m beginning to think that either you’re computer illiterate, or that English isn’t your first language, because that sentence made no sense.

Time to check the basics:
Did you install the Source SDK?
Do you have the game you’re changing installed properly? Run it to make sure.

You will, if using my method, have three files: a .SMD, a .QC, and a .BAT. The file I posted was for the .BAT. Open Notepad, paste that in, and save it as “compile.bat”, not “compile.txt” or “compile.bat.txt”.

Then, just double-click that .BAT file in Explorer. It will run a program called StudioMDL, which comes with the Source SDK. GUIStudio is not involved in this at all. It will run on the command-line, spewing out a bunch of text. If it’s white, don’t bother reading it; white text is OK. Any yellow warnings or red errors, post them here so we can see.