How do you remove error from pointshop with resources?

i have Fox-Warriors Resources Generator to find all the models parts and to paste it into the lua at lua/autorun/NAME.lua
but when i start my server it wont work for some reason because i still have that error.

Pointshop already adds all it’s items (the default one’s) to a resource file.
If you are talking about custom, make sure you are pointing to the folder.
So…



resource.AddFile( "panda.vtf" )


should be



resource.AddFile( "materials/panda.vtf" )


LUA/Autorun:


if ( SERVER ) then
player_manager.AddValidModel( "Bizarro", "Models/Bizyer/slow/jamis/mkvsdcu/superman/slow_pub.mdl" );

AddCSLuaFile( 'assassin.lua' ) ;
end

list.Set( "PlayerOptionsModel", "Bizarro", "Models/Bizyer/slow/jamis/mkvsdcu/superman/slow_pub.mdl" );

--// File Generated By Fox-Warrior's Resources Generator Version 2.05 \\--

if (SERVER) then
	resource.AddFile( "models/Bizyer/slow/jamis/mkvsdcu/superman/slow_pub.mdl" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman.vtf" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_belt.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_belt_metal.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_boots.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_bump.vtf" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_cape.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_cape.vtf" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_cape_bump.vtf" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_eyes.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_sign.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_sign_cape.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_sign_cape_metal.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_sign_metal.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_skin.vmt" )
	resource.AddFile( "materials/models/Bizyer/slow/jamis/mkvsdcu/superman/v2/slow_superman_suit.vmt" )
end

Pointshop.lua:


ITEM.Name = 'superman'
ITEM.Price = 160000
ITEM.Model = 'models/Bizyer/slow/jamis/mkvsdcu/superman/slow_pub.mdl'

function ITEM:OnEquip(ply, modifications)
	if not ply._OldModel then
		ply._OldModel = ply:GetModel()
	end
	
	timer.Simple(1, function() ply:SetModel(self.Model) end)
end

function ITEM:OnHolster(ply)
	if ply._OldModel then
		ply:SetModel(ply._OldModel)
	end
end


Did you check and make sure that you are downloading them? Are you using the server download or a fast download?

fastdl fast download, that one work but not all models can read the reasource!

Could you post or pm me the link to your fastdl, so that I can make sure everything is in the correct folders and that they would be downloadable?

Edit : in case you don’t want to/ don’t trust me, pictures of the folder structure should also work.

the downloading works fine and everything, but all the reasources most not be correct or the reasource generator don’t read it all.