How does one increase the amount of allowed addons in the spawnmenu?

Whenever I click on the Add-ons folder, it disappears. Like this

https://vgy.me/E2EQGB.gif

It works if I remove around 944 addons and run it in offline mode. I have 3,611 addons total in my addons folder, and adding a hundred seems to reproduce the issue.

Help me plz.

You have… 3000 addons?

You rack up a large amount of addons when you’ve been here since Toybox.

How long does it take to initialize the game, if I may ask? :worried:

It has nothing to do with the amount of addons you have, its a problem with the game’s user interface.

This should be fixed in the next update.

Before it started bugging out, it took around 3 minutes to load the main menu and another 5 to load the game map. Now it takes 10 minutes to load the main menu and 15 to load the game map.

I reinstalled my Nivida Capture Card, which is what started this whole mess of problems. It works mostly now, but the loading times still suck.

Well, if I didn’t want to wait, is there a way to brute-force the spawnmenu to load at least 5,000 addons?

You can join the Dev branch and reap the benefits of the future updates right now.

In should have the fix in a day or so.

There’s no other way to do it.

Does this also fix Gmod trying to install DirectX on every single launch?

No, GMod doesn’t install DirectX for you. Steam might, but it’s one time thing.

The dev version doesn’t fix the problem, addons folder still disappears.

Ah. Apologies for missing that bit.

In case you have to set the limit, I’d recommend something insane like 100,000 addons as the spawnmenu limit.

There’s no limit, there was a problem with max panel height.

Ah.

Anyways, this keeps on popping up (the black arc thing)

https://vgy.me/yywtvH.png[/thumb] [thumb]https://vgy.me/TiRMSg.jpg

Some addon, surely.

Found it.

It was the enhanced bucket addon.

Is there a way to turn off Gmod’s autoDoF?

Gmod doesn’t have auto DoF. All you problems are coming from your addons