How the fuck do I start a local server properly??

So I set everything up to explore a very extensive RP map (industrial_17) with a friend on sandbox on a local listen server on my computer. He’s on the same network as me in the same house.
He can connect and all, but everyone is a grey animationless low poly Gordon Freeman with no weapons, and you can’t spawn anything. No errors in console.
The gamemode is set to sandbox in the main menu before I start it.

What do I do? Google hasn’t helped me at all.

Addons:

http://puu.sh/4vkSA.png

(Ignore the red ! markers, it’s just Tortise SVN freaking because I changed the names of those two folders)

[editline]19th September 2013[/editline]

Update: He just started a listen server on his computer instead and on a default sandbox map, and he got the exact same thing. He has some of the addons that I do but not all of them.

[editline]19th September 2013[/editline]

Reading up I heard spacebuild can cause conflicts. Well I just moved it out of my addons and tried again and it’s still fucked. Grrrrrrrrrr

Try running it with no addons.

I did and it was still busted. :v:

But I’m marking this as solved anyways, a friend agreed to run this map on his server. What a guy.