How to add sound taunts in pointshop?

Hello! I am currently hosting a TTT server, and I remembered that sound taunts were possible back when playing on a Deathrun server (Incognito Servers for you who remember it (RIP)).

If anyone could guide me through the forums, that would be amazing! It would also give every other server owner a chance to add this little fun thing to their server. :slight_smile:

if ply:PS_HasItemEquiped(“taunt_xxx”) then

And then what? There has to be some code that makes the sound play and make it reusable, give it a cooldown and whatnot, right?

Interesting for you are:

http://wiki.garrysmod.com/page/input/IsKeyDown or http://wiki.garrysmod.com/page/GM/ShowSpare1
http://pointshop.burt0n.net/player-meta-functions/items#has-item-equipped
http://wiki.garrysmod.com/page/Global/SoundDuration
http://wiki.garrysmod.com/page/Global/CurTime

And the rest should be a bit of thinking.

edit:// if you do not want to code it yourself, try https://scriptfodder.net/jobs/ or the hire an coder megathread

Here’s a nice thread full of options w/o paying

Playing sounds is possible along with creating a system for “taunting” other players. What have you tried so far? Where are you at with your code?

Right now I had a big issue with all my player models, except for (ironically) Kleiner’s. My player models were corrupted (I guess that’s what happened) and they showed the giant ERROR model. I have two theories:

I severely screwed up with the taunts, or it was a Bulldozer addon for the traitors that replaces their skin. I have no idea which one of both is exactly the cause, but I will investigate.

If the error model is showing up, it means the model you’re trying to use doesn’t exist on your client. That can either be from faulty fastdl configuration, not resource.AddSingleFile’ing them, not resource.AddWorkshop’ing them, not allowing mp downloads, etc…

Setting up a server: https://dl.dropboxusercontent.com/u/26074909/tutoring/server_srcds_steamcmd/setting_up_a_server_with_steamcmd.lua.html

Setting up FastDL: https://dl.dropboxusercontent.com/u/26074909/tutoring/server_srcds_steamcmd/fastdl_setup_instructions.lua.html

Setting up a recursive resource system: https://dl.dropboxusercontent.com/u/26074909/tutoring/server_srcds_steamcmd/setting_up_downloads_using_recursive_resource_system.lua.html

Thanks for the info! And… I understand that my client does not have the models, but fastdl does have the models, indexed with resource.AddFile (using Fox’s tool), so even if the workshop puts it in the client, fastdl will do so as well. And btw, from 20 models, 17 weren’t appearing. Only some worked, which must mean that all the files are in the client but there’s just some giant issue. Although, I will try what you say on your tutorial.

EDIT:

I tried re-adding everything to Pointshop, with the files added to my fastdl server (indexed), to the materials and models folder of the server, and now I get this error http://pastebin.com/1wyLskRh

EDIT 2:

Well, I deleted them, and now back to where I started http://gyazo.com/4f0f06ddedd5fde92ed4ac4f8806574f, and this is how it appears to someone else: http://gyazo.com/8ee54323ec55914fb4081a548180dc16

ISSUE MOVED TO http://forum.facepunch.com/showthread.php?t=1434852&p=46392119#post46392119