How to disable picking up with the "use" key?

It’s been quite annoying for me but now it’s become unbearable.

I’m trying to build an engine which requires precision. This means I sometimes have to get close to my props. Then, to get a smartsnap grid lock, I need to press the use key but that also picks the prop up if I’m too close. That’s really slowing me down.

Can anyone tell me how to disable this ungodly annoying feature?

Unbind your use key is an easy fix.

But I need my use key. How am I gonna press buttons and stuff?

edit:
I finally found the solution after a two hour search. You just have to type: sv_playerpickupallowed 0 into the console.

Came here because I have the same exact issue. Glad there was a fix because I was about to start strangling myself with my mouse cable.