How to fix "Ghosting"? (Please Help!)

Hi,

Ive just got my server up and running 2 days ago nicely, about 30 minutes into the game, I get disconnected (but it doesn’t tell me I get disconnect, for me I am still in the game). This happened for each long period of time but that shortened to the point where its happening to me every 2 minutes. I would know ive been disconnected because I would be unable to interact with anything/talk in chat - so I have to reconnect. (you can imagine how annoying this is every 3 minutes for 3 days now)

Apparently, this is called ghosting, and I really want this issue fixed. (from what ive heard its called ghosting)

I have people now (at least 7) that has played my server for days now and they have not experienced this, but me.
Its most probably a client-side issue, but it could be the server rejecting me - im not an expert in this area.

I have tried getting help from hosthavoc.com (rust server provider), but they seemed unsure after our one day talk.

I have tried the following;
Re-installing Rust, validating server files, restarting router, verifying game cache, running Rust as Admin, disabling my in-game ownership/admin, trace route (I haven’t found any problems).

NOTE: I have NEVER experienced this issue with any other game or server in rust. This is the first time, and it just happened to happen on my server. (remember i do not host the server, hosthavoc does). All other plays that play DO NOT experience this issue.

I beg you to help me, because I really would love to play my own server without having to reconnect every 3 minutes.

Information about internet speed/specs:

I get about 30 to 50 ping on average Oceania servers.
I download at about 1.8mb/s through steam.
I upload at about 0.92mb/s (as tested in speedtest.net).

Specs:
Memory: 16GB Ram
OS: 64-bit Windows 10
CPU: Intel ® Core™ i7-490K CPU @ 4.00GHz
Graphics: AMD Radeon R7 200 Series

Thank you.

Is it a home server or is it hosted in a data center? Check your packet loss ingame for at least one minute by pressing F1 and selecting “Network Information”. It should be at 0% permanently.

Hosted in a datacenter. I will use your method and let you know.

[editline]27th March 2016[/editline]

Hi, @dilla

My packet loss remains at 0%, I have waited and tested it for one minute.
I also waited until it disconnected me again and it also displayed 0% packetloss.

Well, if noone else got this issue, you could try to connect to your server via a free VPN Service. Of course, this could cause other issues, since you can’t know, how reliable these providers are, but if you won’t be disconnected then, you can be pretty much sure, that this issue is related to your ISP (routing between your ISP and the data center’s carrier). If possible, you can also ask your neighbour for a wifi access.

What router are you using (please don’t say Telstra)?
Are you using Wi-Fi / Ethernet / Internet-over-power?
Is a phone or tablet connected by Wi-Fi at the same time?

As well as answering these, can you open up Task Manager, and look at your internet connection graph and then play any 5minute YouTube video on 240p then 1080p - is there a steep drop at a recurring interval?

Before answering any of these questions I’d just like to point out the fact I think it is a client side issue, my internet was never the host of my problems nor did it encounter any.

Take note that when I apparently disconnect, I an unable to interact with anything or type in text. But I had a couple of friends with me, while I think im disconnected I could still move around and they could see me doing so. They could also see me placing foundations if I tried to but i couldnt see it myself.

Maybe its not a connection issue? At some point in the game it forbids me to see my interaction with the server while still being in it (same going with typing in chat). Therefore I have to reconnect if I want to see these things, only for it to happen again a couple minutes later though. Its very weird.

That really sounds like packet loss. And you’re sure, that this happens only on this specific server?

I am 100% certain.

Well, you said, that you don’t have this sort of issue on other servers. Therefore I’d say it has to be a connection issue between your ISP and hosthavoc. I personally would try to find another hoster then. Your current hoster should also be able to hand the save files out.