How to fix No Hud for amd graphic cards!

This is for people who have a amd graphics card that have no HUD cant see the crafting or the inventory stuff in that nature

all you have to do is download http://support.amd.com/us/gpudownload/windows/Pages/auto_detect.aspx

do all the setups and it should work :slight_smile:

wow downloading drivers improves GPU functionality i never would have guessed!!


(User was banned for this post ("Don't be a dick" - MaxOfS2D))

Dont know if thats sarcasm or not

It is, ;).

Yes I can verify this, updating my drivers fixed the no hud thig. The new drivers are buggy as hell tho.

well i was just trying to help XD

Same thing for all graphics cards, if you have any problems, first thing to do is update your drivers.

Quick phone the police

Already tried this, didn’t work.

worked well for me and my 2 friends

On laptops or desktops? Which graphics cards?

I have ATI Mobility Radeon HD 5650 on my Acer Aspire Laptop, everything is working fine.
You can try installing ATI Catalyst 12.3 and see if that solves anything. I have experienced BSODs with later versions, so don’t ask why I use old version.

Funfact: The program from OP never worked for me.

I’ll give that a shot!