How to get hammer working 120% again

We all know that with the new steampipe update, our beloved hammer from SourceSDK is giving us grief.

Well this guy managed to find a fix for it:

For anyone too lazy to watch the video, here’s what you gotta do:

Step 1: Navigate to steam/steamapps/common/Team Fortress 2/bin

Step 2: Locate the hammer.exe in the bin folder. Make a shortcut or whatever you want with it unless you live navigating to the steam/steamapps/common/Team Fortress 2/bin whenever you want to start hammer.

Step 3: Navigate to your favourite game folder (CSS, EP2, Portal, whatever) and copy the folder that contains all the data (see table below for the folders)

Step 4: Paste the folder into steam/steamapps/common/Team Fortress 2

Step 5: Run hammer, set up your options manually, and make awesome maps.

Hope this helped.

Table showing where your game folders are that you need to paste into Team Fortress 2 so you dont get the gameinfo.txt error.
[table=“width: 500, class: grid, align: left”]

Half-Life 2: Episode 1
Half-Life 2: Episode 2
Counter-Strike: Source
Day of Defeat: Source

steam/steamapps/common/Half-Life 2/episodic
steam/steamapps/common/Half-Life 2/ep2
steam/steamapps/common/Counter-Strike: Source/cstrike
steam/steamapps/common/Day of Defeat: Source/dod


Didn’t they already release the sdk tools for HL2 steampipe?

Maybe. I don’t know I haven’t gotten an update or whatever on either of my machines. This way loads hammer faster then before.

If there are sdk tools for HL2 steampipe then where are they?

Right here.

That’s not HL2.

Once you are in the HL2 Steampipe beta, hammer.exe is located in steam/steamapps/Half-Life 2/bin

Wait, SDK content is now on the SteamPipe beta? THANK YOU

Sweet! No longer do I have to be forced to map for Black Mesa or CS:GO!

Here’s a full tutorial of how to get it all working again if anyone cares:

It’s better to use hammer.bat which will setup the VPROJECT.