How to give myself admin, so I can access the ASS mod menu?

I have made a console-based, dedicated server. I have ULX admin but i can’t access the ASS mod-menu. I really have no idea how to do it. Please help!

Well, there’s your problem, you are using ULX and are trying to access another admin mod’s menu.

!menu is for ULX.
+ASS_Menu for ASS Mod.

I think it’s this command you need to use.
ass_giverownership “yournamehere”
With out “” of course.

Write it in “rcon”

If you still don’t get it read this:
(write in console)

Step 1.
Write rcon_password “yourrconpass”

Step 2.
Rcon ass_giveownership “yourname”
If you are not using rcon just write: ass_giverownership “name”
And then you skip step 1.

  1. Bind your ass_mod and then it works! :smiley:

Thanks very much this helped a lot.

Wrong, it’s ass_giveownership “client_number”

Go to rcon or console and type status, there will be a number next to your name, use that number, not your nickname. That’s how I give adminship to everyone.

ass_giveownership name
(or as stated above you could use the client number)

then

bind key +ASS_Menu

Enjoy!

when i do it, it says access denied

You need to enter your rcon password and then execute the commands.

so basically

rcon_password <password here>
rcon ass_giveownership <your name here>

I think we are feeding a troll.
Who calls themself “OMFGLULZWTF”?

do i have to redo this every time i restart my server? cuz i have to edit it a lot…

the real command to give yourself ownership is this ass_giveownership “user id” you can see your user id if u type status in console and there is a whole line like this 1 “sock_myclock” STEAM_0:0:1233645455 and so on… copy that whole line to your command so it looks like this ass_giveownership 2 “sock_myclock” STEAM_0:0: 1233645455:07 25 0 active loopback

i have a similar problem and i cant get ownership i have tried everything and can someone tell me what rcon is my server is working i just cant get ass mod to work but evry time i try setting owner it says access denied ?nevermind about rcon just how do i set up a pass word for rcon

Hey,

I followed all of your instructions and this error apeared:

ass_server.lua:40: attempt to compare two nil values

any ideas?

I think ASSMod finally broke.

Why do you feel the need to use TWO admin mods anyway?

Yeah assmod’s been broken for a while. Thank God.

Problem 1. If you have ULX you cannot access ASS mod
Problem 2. If you have a dedicated server, you must go to the garrysmod folder and add your steam name and id to the users thingy

[editline]10:01AM[/editline]

assmod still works -_-

Assmod Stuff you need to do to make you admin

Rcon_password <yourRcon>

Rcon ass_setownership <1-**>
That number do you get from Console command Status. its the first number. If you are the first ppl that join you got Number 2 .


Important to do this to make ppl happy.
Just make a Search for Gramm And you find it :stuck_out_tongue:
Go on Orangebox/garrysmod/addons/assmod/lua/plugins/grammar.lua (NOT SURE)
If you delete it ppl can Write WTF OMG OMFG with out saying stuff like “WHAT THE FURGE”
And you don’t have to do a Dot after every Fucking stuff you write :stuck_out_tongue:

have fun :))

Why do you need ULX and ASS mod at the same time?

I don’t think Assmod bans work, atleast it didn’t for me.

Also I think there’s a textfile somewhere in the Assmod about who should have admin and so on. Don’t know though, haven’t used it in a while :downs:

guys i really need help, set my server password to *****, start server up, join in, rcon_password ***** all it says is
] rcon_password *****
then nothing, then i try
rcon ass_giveownership
Bad RCON password
tryed adding myself to user.txt still same thing, this is really getting on my nerves