How to install "GLIBC 2.15" for debian servers.

Ok, so you may get the error stating:


 Failed to open dedicated_srv.so ( /lib/i386-linux-gnu/libm.so.6: version `GLIBC_2.15' not found ( required by bin/dedicated_srv.so ) ) 

Well, here is how to fix it!

First do:


wget https://launchpad.net/~ubuntu-security/+archive/ubuntu/ppa/+build/6220080/+files/libc6_2.15-0ubuntu10.6_i386.deb

Then do:


 dpkg -x libc6_2.15-0ubuntu10.6_i386.deb tmp/ 

And then:


 cd tmp/lib/i386-linux-gnu/ 

And finally


 cp * /your-garrysmod-directory/bin/ 

Why am I writing this?: Because the official link for libc5_2.15 (10.6) is now not available, but is still needed for many gmod servers!

Tell me if this helped…