How to make a gamemode work?

I am working an a simple gamemode called Assassination. I have two player classes and the shared.lua all done, and I am ready to play. But that’s the thing: I can’t. I put it in the gamemodes directory and it should be working fine, but whenever I go to the options to select it, all that shows up is sandbox and fretta. What the hell? I don’t know what on earth to do. Please help!

Make sure it doesn’t have spaces in the Gamemode name or special characters.

You need to add an info text for credits too

Thanks, I’ll try those suggestions.