How to make lava, and make it cast light

any techniques to make lava in source?

Pretty sure you can make the texture itself emit light by adding the texture name to lights.rad. But that will probably make light go through your displacements if you’ve got any.

I suggest you make a water texture with custom flow maps or an animated texture. As for the emissive light, just use light entities. You can scrip the light entities to constantly decrease/increase brightness for a more realistic behaviour.

I had made a custom shader using flowmaps and it worked perfectly for lava, it looked incredibly believable, and for lights, I don’t have any screenshots here though, and using lights.rad works good also for illuminance

I don’t have time to look for myself, but I remember this map having awesome lava near the runner/CT spawns.

definitely a custom texture.

I’ve made a lava texture for ColdSteel:

let me know if you want it, I can send you the files.

But that doesn’t look like lava. That’s just the photoshops clouds filter.

sure thing send me pm with it

thanks to this, my map looks more epic now

I expreimented with lava a little for my map gm_lair. if you want completely liquid lava, it’s best to use an unlit/ light emitting texture.
In my case, where there were solid areas in the lava, which had a normalmap that should remain visible.
The best solution was to make the lava spots $selfillum and manually place lights above them, so the surrounding normalmap would be lit nicely. That method worked out best for me, but again, it depends on the type of lava you want.

I used this filter from FilterForge to generate the different channels of the texture (it’s noisebased).
There are also many other lava and magma filters in the user library.
If you want to use them, but have no FilterForge, just say a word and I can render some for you, or you can get the fully functioning demo…

Instead of using $selfillum, you can just create a brush with big minimum light level values

Wouldn’t that make the entire texture bright instead of only the actual bright spots in the lava?


The $selfillummask-parameter didn’t work for me.

I had do add “$selfillum 1” to the vmt and make the selfillummask the alphachannel of the albedomap to get it to work (At least for Half-life2 / Gmod).
May have had something to do with the $bumpmap, which is incompatible with the $selfillummask if I remember correctly…

I did the same with my lava material. isn’t $selfullummask used when you have that mask in a separate file? so you can have things like transparency and selfillum parts for the same material?