How to make steam stop updating GMod?

Well, since I mostly play SP, quietly constructing or playing with wiremod, I don’t really want new features that badly, I’d much rather sit in a corner and wait until the new update breaks everything, then Garry fixes it, then wiremod team fixes their stuff again, and THEN I’d update.

Before you tell me to go to “options->updates->[do not update this game]”, I did that. The next morning, it’s set to [always keep this game up to date]. Same stuff the next day. What do?

Disable your internet connection.

You might have to stop any other Source games that use the same engine version (CS:S, DoD:S, TF2, HL2:DM) from auto-updating too.

Makes since as garrys mod needs a other game to run off.

Turn your Online off If you Want to play on multiplayer you have to download it.