How to remove shine in Half Life Mwodel Viewer and how to load the Gravgun?

Hey, I made some player models and I am testing them in Half Life Model Viewer. One problem, some models look really shiny. Example, I am doing a COD 4 SAS guy and his model is shiny. I can’t get a pic because paint is broken one more

The second issue is loading the Gravity Gun weapon. When I test the player and I show the Grav Gun animations I want to use the Grav Gun as the current weapon but it doesn’t spawn

Not sure about the Grav Gun loading (as i’ve never gotten HLMV to actually load something right) but the shiney sounds like missused envmaps to me, go in and delete this line if it shows in the VMT files for the model textures:


$envmap "env_cubemap"

That’ll stop it (theres been other people saying about the shiney on those models aswell). If theres any other lines that have the word “env” in them you can safely delete them aswell but they will be redundant without the $envmap line so you don’t need to. Alternatively you can put “//” infront of the line like so:


//$envmap "env_cubemap"

That will also disable it.

Thanks Silver, the Env deleting worked

np :slight_smile: as I said theres been a few people asking about that (thankfully I didn’t have to tell them all myself :P)

I think ticking the normal mapping box fixes it as well.

Someone forgot to enable a normal map? I always used to do that :stuck_out_tongue:

Why does that affect the env though? Is there this line in the code?


$normalmapalphaenvmapmask 1

As that would explain it.

It seems to affect the env map regardless. I don’t know why, it’s the same with phong.

Normal maps usually contain alpha channels which are used to control phong and envmaps.
Disabling the normal map will make the program think the non existent alpha channel is pure white, and so the envmap becomes horribly strong, making things look like chrome.

Yea thats why I was asking if it had that line in the VMT, you need that for the normal’s alpha channel to be used for the specular map. I think it uses it for phong as default though from what i’ve read.