How to Scale Ragdolls in 3DS Max?

Issue has been resolved. Help is no longer needed.
[del]So I have this scaling issue where the ragdoll is too big and I want make the ragdoll smaller to match up with the ragdoll (I used Ragdoll Resizer to make it smaller.) on the left.

http://images.akamai.steamusercontent.com/ugc/448457570803034381/C6CFF88D1B232F9077DB511259B53D7EE8C966B5/?interpolation=lanczos-none&output-format=jpeg&output-quality=95&fit=inside|1024:640&composite-to=,|1024:640&background-color=black

Problem is I don’t know how to scale a ragdoll in 3ds max and I couldn’t find any suitable tutorials that talks about this specific subject. So my question is how do I scale ragdolls using 3DS Max 2012?[/del]

You should be able to just select the bones and scale them uniformly. Import a reference smd for size comparison. Export again and voila

To scale, hotkey is “r” and select the inner triangle to scale in all directions.

Alright, I got that. But what if I want to scale to a specific percentage say like 42.5%?

Edit\Transform Type In or F12.

Hm. I remember wallworm told me never to scale the bones as that break the bone weights.

http://images.akamai.steamusercontent.com/ugc/448457911085531322/E398D73C75ADF94D8ED3259BC2FF638FDD2DFF75/

Well looks like I found it the hard way, it appears it caused more problems than it actually fixes or I probably didn’t do something right.

Anyone got a way to scale a ragdoll without breaking the bone weights?

Use Xform modifier on the model after you are done with everything

Alright, so I put an XForm modifier, but there are two more options, Gizmo and Center. Do I anything about those?

Oh crap I’m not sure, I believe it is just that you are transforming (moving / scaling / rotation) either from the model’s current Gizmo position (see pic) or the model’s center.

http://www.3dmax-tutorials.com/graphics/ico_move_gizmo_centerbox.gif

(Gizmo)

I am not too sure which one, but I think I am transforming in the model’s center. I am going to check when I get back.

It appears that the current gizmo position is at the same place as where the model’s center is.
Problem now is what I am suppose to do now?

Just scale it! Gizmo’s position will only be likely to become offset when one is modeling from scratch.
Frankly I’m not sure if the bones need Xform as well, but you could ignore it until proven problematic!

(Oh, you should move Xform up the hierarchy, above Skin)

Still got nothing.
I probably need to rescale the models again since I scaled without putting the XForm Modifier first beforehand.

And another thing, it seems scaling with gizmo, it only scales the model itself not the bones at all.

Scale the bones and the model at the same time and make sure the model is still rigged

You could also use $scale, https://developer.valvesoftware.com/wiki/$scale

If I do that, I end up not selecting the XForm modifier. Still, I will see if that works.

$scale doesn’t work as that end up squashing the model anyways.

Whelp. Even scaling both the model and bones and as well as putting in the XForm modifier.
It still doesn’t work.

Am I doing something wrong? Also, is there another way to scale ragdolls without breaking the bone weights?

You’re scaling the collision model as well, right?

The physics model? Yes, I did.

I usually select everything using ctrl+a then right click the scale icon on top of the screen. then just mess with the scale on the right side which scales the whole model on all axis.

Which is what I exact did. Except I just F12 to open up Edit\Transform Type In dialog box and then type in the percentage I want to scale the model. But either way, it still doesn’t make a difference.