How to set default commands? Or how to fix certain textures from being bright on a map?

Currently have an issue with some textures being really bright. Example: http://prnt.sc/cdd5vj (The textures on the gun). Looked up my issue and a fix seems to be to put in the console command “mat_specular 0”, but this command automatically resets every time I close Garry’s Mod. Meaning if I close Garry’s Mod, the bright textures come back making me have to do that command again. Is there a way to default this command so that it runs every time I open my Garry’s Mod or is there any type of permanent fix to this issue?

Try putting the command in your client’s server.cfg and autoexec.cfg. Not sure which if any run on the client.

Works! However, every time I change a video setting, some textures go back to being bright and I have to restart gmod or put that command in console again. Not that I change my settings frequently, but there has to be some type of other fix, right?

Unfortunately, no. It’s a Source bug