How would I make Zombie and Combine NPCS?

Ok, so I know how to make NPC and players but I seem to be having some trouble with the Combine and zombie

The Combine

I tried original animation line $includemodel “models/combine_soldier_anims.mdl”

No luck, just t-posed

Now Silver Spirit helped again and posted some custom animations he had. Once again, no luck

Here is how I set the original animations up

http://filesmelt.com/downloader/Combine.JPG

The lua file is set

http://filesmelt.com/downloader/Combine_2.JPG

Zombie

Ok, so I am working on FP personal skin NPCS and I got up to working on Sliferz zombie skin. Now for some reason when spawned, it just spawns the original zombie model

The QC

http://filesmelt.com/downloader/sliferz.JPG

The LUA

http://filesmelt.com/downloader/Sliferz_2.JPG

Any help would be great, trying to make a NPC pack

What? my ones didn’t work O.o, now that is worrying (as all most of them are are a single reference to all the required anims for a certain set such as Alyx or GMod Player), I will need to test them again but they worked fine last time i tested :S

Zombies are obviously one of the NPCs that don’t change their models with Lua. Use Silverlan’s code I posted in you thread for a way to get them to work.

Try getting rid of “cs_fix.mdl”

I just realized why they won’t work. The NPC names (the ones after list.Set) have spaces in them, when they shouldn’t. Replace the spaces with a _.

So it would be like Sliferz_Zombie?

I was thinking that but there has to be a way to have them both as players and NPCS

Yes it would.

Ok and would that go for other zombie and/or Combine NPCS? Example Chesty’s skin I had “Chesty 2” and it worked without _

Well it is always good to make sure there is a _, just in case.

You can, its fine to have both as they reference completely different anims.

Thats strange, but then again mine have been pretty inconsistant like that, its best to not have spaces in lua names from my experience (i’d suspect its thinking your putting two values where there should only be one and thats why it’s going nuts).

Also jason get your butt in the release section we’re (I am) actually doing some stuff thats DC related for once :stuck_out_tongue:

Indeed, if the lua file’s name has a space in it, it usually dies aswell.