HTML panels broken?

They act really weird. Sometimes they display, sometimes it’s just blank. Anyone knows what’s up? Garry mentioned he would check them out on Twitter but I don’t think he’s fixed it yet? Or has he?


(User was banned for this post ("Use the Help & Support section" - Orkel))

That’s cuz theyre broken.

Garry was looking at implementing a new HTML rendering system using Awesomium.

At the current time, they should be working at all, not sure why yours would work.

You’ll have to wait until the new renderer gets implemented for your pretty MOTD and the such to work.

No… they work somewhat… But most of the texture rendering from HTML panels are busted to high heaven…

Well, is he planning on fixing it soon or after Gmod 13, or what?

Hes trying to fix it as quick as possible. I think he is more concerned about the srcds.exe messing up at the moment.

Anyone has any creative temporary solution besides using forcing steam browser open?

Just fyi, awesomenium seems only to be implemented in gm13.

It’s still glitchy in gm12, I found a small workaround though it doesn’t always work.

I just decided to implement VGUIs for everything that was HTML panels.

I thinks sv_loadingurl is broken too, because is HTML right?

Because I see my page in the console (is loaded) but its never appears…

Sorry for my bad english

It will be fixed today.

The Update is installed, but my loading screen and my HTML panel still broken…

Weird. Worked fine when I tested it.
(Didn’t test the loadscreen)

If your loadscreen is flash you will need to make sure you have the appropriate plugin installed

I can load the page with Firefox with no error in firebug, and I see the page loading in console when i’m connecting

Log of my console:



Browser Message: Uncaught SyntaxError: Unexpected identifier - (null):0
Browser Message: Uncaught ReferenceError: DownloadingFile is not defined - (null):0
Browser Message: Uncaught ReferenceError: SetFilesNeeded is not defined - (null):0
Browser Message: Uncaught ReferenceError: SetFilesTotal is not defined - (null):0


I see this error on any server I join, and each time, the loading screen not appears

edit:
My page: http://lostofroleplay.rd-h.fr/Page_Dl/index.php
In gmod, I see a White page…

Same for us. HTML panels still a white page, we updated the servers too. We’re not using flash either.

This patch works for some and not for others, what the f*ck ? =/

It works on our development server but not on our live servers. I don’t even know what’s going on anymore.

garre pls fix

he fixed for GM12… I dont know about GM13