Http.Fetch always returning onError callback.

My server’s http.Fetch appears to always be running the orError callback not long after init.

The first fetch to run works (which gathers my jukebox data), but after that all callbacks don’t.

I’ve tried it with a variety of URL’s aswell, such as google, facebook, and anything that should be connection fine.

Not sure what is causing this, and the only way I manage to fix (for one map), is by rebooting srcds.

Any help is highly appreciated, thanks.

PS. I didn’t bother supplying any code, because the functions work perfectly on my development server, but not on the main servers.

bump :frowning:

Yet another shameless bump, so I can actually get stuff working :S

Did this only start after an update?

I’m honestly not sure.

It would seem that it’s been occurring a lot since it though.

Have you tried deleting the bin folder and doing an update? That would make sure the server files aren’t corrupt somehow.

Welp, even at the risk of looking like an utter moron, it’s magically started working after 2 days of no http.Fetch.

Didn’t verify, didn’t do anything.

Fuck logic, marking as solved.