I can only walk?

I reset everything to default, even re-downloaded the game, and all i can do is walk… cant jump or when i press 1 2 3 4 5 or 6, i cant see what im selecting. also there is a black border on the top and bottom of my screen when im playing?

[editline]30th July 2015[/editline]

i cant shoot or click anything either.

Post a picture?

Um whenever i drag a screenshot in here it just shows up over the entire screen :confused: but do you know anything about the no jumping? because i can only really switch items and walk.

Upload a picture to http://imgur.com and post a link.

Your broken controls can be explained by two things:

  1. An addon fucks you over ( Find it, Remove it, try disabling all addons )
  2. Your controls are bound incorrectly ( Go to Options > Use Defaults > OK > OK )

Ok that worked. Thanks! but 1 more thing; the num keys hud is not there? i cant see what im selecting

Num Keys HUD?

[editline]6th August 2015[/editline]

Oh you mean the weapon selection?

Disable Fast Weapon switch:
Options > Keyboard > Advanced > untick Fast Weapon Switch > OK > OK

Ok, that worked. Thanks!