I can't figure out why I lag in Gmod Muliplayer

Here are my PC specs -

GeForce GTX 660 Ti

Intel® Core™ i5-4460 CPU @ 3.20Ghz

16.00 GB Ram

350 Watt Corsair Power Supply

1000 GB SSHD

1920 x 1080, 60Hz

Microsoft Windows 10 Pro

I’m really confused about how I’m getting such bad FPS, In the loading menu I get 200+ FPS, but the second I load into my favorite server I drop to around 6 FPS. In single-player I’m getting around 30 FPS

My internet speed is great with a stable ping of around 30. I’ve even port forwarded Gmod to speed it up. With or Without the port forward its the same

Using FurMark I get 60 FPS without fur, and 30 FPS with it.

I’ve tried using -dx level 11 and all that crap and none of it works :confused:

And yes my monitor is plugged into my graphics card

Thanks in advance if you can help

Does disabling v-sync have an effect?

Make sure Garry’s Mod is using your graphics card and not on board graphics.

I have not checked, Ill check if Disabling/Enabling V-snyc works

How do I check if gmod is using my graphics card?

No V-Sync does not make a difference if its on or off

Go into the Nvidia Control Panel and make sure Garry’s Mod is set to use your Nvidia GPU.

Lag is how long it takes for your connection to reach the server host. I.e, You can be living in America whilst the host is in Australia, so the connection may be good. Here is some tips on how to prevent lag.

  1. Don’t get DDosed. Don’t give your IP to anyone, unless they are very trusted friends or relatives. Otherwise, DON’T GIVE OUT YOUR IP
  2. Used wired connection. Use wired connection to your computer instead of Wi-Fi, it works much better.
  3. Have good range with the host.

Lag can also be caused by having a slow computer, or addon overflow.

I never give my IP out. I do use a wired connection. I have good range with the server. I have a good pc and only 44 addons for the server

[editline]18th July 2016[/editline]

Just to clarify This is what it looks like and inside the All iv’e checked my 660 tti

What are your options for mixed-GPU-acceleration? I don’t have that feature on my GPU but it looks like something that could be trouble.

Also, that appears to be the options for Half-Life: Source, not Garry’s Mod.

These are the options for the mixed-GPU-acceleration https://gyazo.com/bdbd1daaa313e2cee0973f0768737bdc

And Gmod shows up as Hl2 - https://gyazo.com/a87da48c03a243b407ad17728e0fc4c7

Bump, Still no fix

Maybe game uses integrated card instead of Nvidia card.

Check for high performance Nvidia GPU in the global settings:

don’t kill me for comic sans please

You can also try for right-clicking the game executable and opening it with Nvidia GPU.

If you want more FPS, try to enable multicore rendering - just type these three commands in the console: