I can't play :/ (connection attempt failled)

I, like the title says, i can’t play in any server, it always says “connection attempt failled”.

I was able to play, like, 2 months ago, and now i can’t, and i didnt changed anything, well, the game has updated, obviously, but thats it. I tried unninstalling and installing again, nothing changed.

I’m sorry if this problem has been said before, and it was solved, i didnt find anything about it, and i also apologize if this is not the right place to ask for help.

Anyway, i would like some help on this, please :).

Thank you.

I’ve had this problem, I think it’s the same one. What you do is you go to the server you want, press connect then disconnect while it’s still trying to connect, then press re-connect, I hope that works for you, It’s worked for me in the past.

Well… it kinda worked.

I tried that, it didnt work at first, or the second or the third, then i ignored that message for like 5min, then i tried again and it worked xD

Why this happen, anyone know?