I can't run Rust on dedicated graphics card - Help, please!

Hi everyone

I have recently bought Rust, but I haven’t been able to play properly because the game keeps running on mi integrated Intel HD 4000 graphics card instead of the dedicated one (Nvidia GeForce GT 740M). I’m only having this issue with this game.

I’ve searched a lot and found some people with the same problem, but so far I haven’t found any solution. I already tried setting the game to run with dedicated graphics from the Nvidia control panel. I’ve even disabled the integrated card and tried to run the game, but it didn’t work because the game didn’t use the dedicated card, it was just unplayable.

I don’t know what else I can try, so any suggestions will be appreciated. I really want to play this game with proper visuals and FPS.

Thanks in advance!

PS: I’m sorry about my english, I’m not a native speaker


EDIT: Problem solved. Thanks to elixwhitetail.

Hi, What is strange you say , I play with a Nvidia Geforce 210 Rust imagine . You use windows? What is He who fails you ?

Yes, I’m running windows 8.1. I don’t really have a clue about what’s causing this trouble.

Unity likes to glom onto the integrated GPU, but this should force it. You may also be able to get things sorted out by creating a profile for Rust using Nvidia Inspector and forcing the GPU selection in the profile.

I’ve already tried changing the settings from the nvidia control panel, but it didn’t work. I will try using Nvidia Inspector and see what happens. Thank you!

You’ll likely need to set Shim Rendering in the profile. Make sure it’s set to “SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE” for Rust, and that should override the integrated graphics.

It worked! The game is running fine now, I really appreciate your help. Thanks

where u put the command “SHIM_RENDERING_OPTIONS_DEFAULT_RENDERING_MODE” ??

In the Nvidia Inspector profile, as the option under Shim rendering mode.

Hi, i put that option in nvidia inspector and still doesnt work, what i should do?

The same is happening to me, nothing I try seems to work on direct x 11. However on directX 9 something weird happens, and although Rust says that Intel Graphics is being used. It says that it has 900-980mb of memory (it varies each time I run it) instead of 128mb from Intel Graphics has on directX11. It also displays the fps on top left as other games do. So I am not sure if it is using nvidia’s proccesor or not, but seems like its using the memory.

Upgrading to Windows 10 didn’t help.

After countless searching and jumping between topics, I think I found out the solution.

At first, I tried going through nVidia control panel and tried changing there, but it kept resetting.
Turns out that nVidia didn’t had enough permissions to change anything.

So I did this:
Went to C:\Program Files\ and found the folder “nvidia corporation”.
Then Right clicked -> Properties and then found the permissions.
Then I gave “Full Control” option for all profiles.

After that, changing worked in nVidia control panel (change in the global settings, so that “Preffered graphics card” would be the dedicated graphics card) and Rust actually used the right graphics card.