I can't run TestLevel server

When I run a server on TestLevel Map returns an error on the console and can not connect it.

Have a solution?
Detail: ProceduralMap works perfectly!

Thanks!!!

ProceduralSmall

Thanks!

Thanks for sharing your rcon password. Probably want to change that now if your server is accessible to anyone outside your local network (i.e. your house).

So, um, I am a bit confused, sorry. I am trying to make mine a “Testlevel” server so I can mess with the new building system before going back to work for a few days.

What do I need to do here to test the latest code?


@echo off 
set EXELOCATION=D:\Games\steamCMD\steamapps\common\rust_dedicated\Release\RustDedicated.exe
set EXEOPTIONS=-load -autoupdate -batchmode +server.hostname "|US East|RustaPro|Friendly|" +server.port 28015 +server.identity "Rustapro" + +server.seed 692823 +server.maxplayers 200 +rcon.port 28016 +rcon.password "***"
set STEAMCMD=D:\Games\steamcmd\steamcmd.exe
set STEAMSCRIPT=rust_ds.txt

Or change something here:


@ShutdownOnFailedCommand 1
@NoPromptForPassword 1
login anonymous
force_install_dir D:\Games\SteamCMD\steamapps\common\rust_dedicated
app_update 258550 -beta experimental validate
quit

Sorry to hijack a thread, but I am dying to get accustomed to the new stuff before going back on the road. Thanks for your help.

+server.level ProceduralSmall

Here is what I have now:


set EXEOPTIONS=-load -autoupdate -batchmode +server.hostname "|US East|RustRepo|Friendly|" +server.port 28015 +server.identity "RustRepo" +server.seed 692823  +server.level ProceduralSmall +server.maxplayers 200 +rcon.port 28016 +rcon.password "***"

That is correct? I am still not showing on the server browser. So If i have this correct, then it is something on my end.

Thank you for your help. :slight_smile:

Just a tip, the following:



-load


is not needed anymore, as it loads by default.

Thank you!

I have been trying for a day or two now, and still cannot get my server to load the dev branch. Can someone who has a dev server running share their command line parameters? If someone know the parameter(s) please share it? Thanks again.

The pipe characters are going to very likely trip the server browser filter. Take them out.

I’m not sure what’s keeping the server from loading, though, as I haven’t played with the development branch DS any.

You’re using -beta development in the SteamCMD command to get the development branch, right?

Thank you SO much! I was at wits end. Google searches returned the release version information, nothing about how to switch over to dev branch. I was using -beta experimental, and knew there was something I needed to change.

Luckily the server browser hasn’t axed me yet. It is a good suggestion though, so when it does I will change them. Thank you again, I honestly appreciate it.

Mark as solved.

Notice that the live testing branch isn’t called “experimental” anymore, but “development”.

-beta is to get SteamCMD to pull the server equivalent to match your Betas tab in Steam. “development” is the live branch for what used to be the “Experimental” version of Rust, which is now simply Rust. (And legacy is still legacy.)

a change to the server settings

So now we can pick the size of server map :slight_smile: so cool

Edit: Or maybe not it seams jenkins has all the rust stuff disabled apart from the rust-megabuild and no updates to server or client in last 25 hours,

my server is running build 2009 and i am on the latest client but they are incompatible versions. Doh.