I join a server then i either black out or crash

I played gmod before they added the “toybox” update and it worked fine, except for crashing with server crashes every now and then. But now whenever I try to join the SB server i played on all the time. But instead of working it now blacks out the whole screen, or it shows me the spawn menu and the box that pops up when you first join the server, then I crash. Idk what to do because it worked before and its bugging me. I’ve updated to all current widows updates.

here are the specs i pulled up for DXDIAG:
Intel Pentium 4 CPU 2.8GHz
2560MB RAM
ATI Radeon X1650 Series
SB Live! 24-bit

Hope you guys can help cause i built something on that server that i really want to DL for my personal files again.

Your hardware is a bit dated. Does it occur anywhere else or just that server?

Get more RAM!

Don’t listen to these two, your syste, can run it just fine, could it be your addons conflicting with the game itself?

He surpasses the minimum…

Try setting the launch options for GMod to -dxlevel 7, -dxlevel 8, -dxlevel 9, -dxlevel 90, or -dxlevel 95
See if any of them work.

how is 256>512 to you? he has 256mb of ram while the minimum is 512 mb. guessing the age of your pc this’d most probably be ddr133 ram. this isn’t that expensive to upgrade. for about $20,- you could buy an additional 512mb of ram. and fix your problem

You’re lucky you could play at all till now

  1. It’s 2 gb’s of ram with a 3rd chip added from the sticks that came with it it.

  2. I have Phx3 Wire mod SBMP SBEP v5 SG and Doctor who, but like i said I had all this before the update and it worked fine.

  3. I dont know what the other guy said to do because other then Sandbox and SB idk what Gmod can do, or how to alter anything on it.

Well, rename your garrysmod folder, start up gmod, and see if it still crashes.

I did that, and i just joined a regular sandbox and something else happened. My screen faded into white. I’d hit the escape button and the menu would show up but when i closed the menu the screen faded into white. Also Idk what to do with -dxlevel 7, -dxlevel 8, -dxlevel 9, -dxlevel 90, or -dxlevel 95, or even how to use them so i can’t test that…

Go to your games libary -> Right click on Garrysmod -> Launch options. Then put -dxlevel 7, -dxlevel 8, -dxlevel 9, -dxlevel 90, or -dxlevel 95. 1 of those.

He said 2560mb of RAM unless he made a typo…

That’s approximately 2.5 GB. Chances are there’s 3 GB RAM in there, but a chunk of it is being used by the video card (therefore it’s integrated…yuck, but at least it’s ATI and not Intel)

[editline]06:11PM[/editline]

Valve took DirectX 7 support out of the Source engine.

It’s -dxlevel 80. Or -dxlevel 81, in some cases.

Source by default runs on DirectX 9, so setting it to DirectX 9 in launch options would make no sense

Thanks, that worked, im able to go back on my Favorite server! thanks for whoever suggested the dxlevel

scratch that, back to the same problem. It worked once now it’s not working again. idk what to do. I windowed the game, I switched it to every level you guys mentioned. Idk whats causing it…

Idk if this helps anybody but for some reason my game keeps synchronizing…

It synchronizes after long game plays I notice.
Have you rechecked your shorcut options, it may have reset to default with the -DX option on it

idk what you mean…

I really need some help!