I keep getting this error

I keep getting this error whenever I try and add custom jobs.

[DarkRP] gamemodes/darkrp/gamemode/modules/base/sh_createitems.lua:442: bad argument #1 to ‘floor’ (number expected, got nil)

  1. floor - [C]:-1
  2. createJob - gamemodes/darkrp/gamemode/modules/base/sh_createitems.lua:442
    3. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/jobs.lua:24
    4. include - [C]:-1
    5. loadCustomDarkRPItems - gamemodes/darkrp/gamemode/libraries/modificationloader.lua:111
    6. fn - gamemodes/darkrp/gamemode/libraries/modificationloader.lua:119
    7. Call - addons/ulib/lua/ulib/shared/hook.lua:183
    8. unknown - lua/includes/modules/gamemode.lua:35

TEAM_BUILD = DarkRP.createJob("Builder", {
	color = Color(255, 255, 255, 255),
 	model = "models/player/Group03/Male_03.mdl",
	description = [[You build things for people.]],
	weapons = {"weapon_gphone", "weapon_fist"},
	command = "builder",
	max = 4,
	admin = 0,
	vote = false,
})

You didn’t give them a salary? Actually, you’re missing a lot of required fields. Check this article for how to properly create a job.

Also, try and use the same thread, instead of posting a new one.

Sorry new to this.

I get this now and I’ve added all the required fields. Thanks in advance

[ERROR] addons/darkrpmodification-master/lua/darkrp_customthings/jobs.lua:32: ‘}’ expected (to close ‘{’ at line 24) near ‘admin’

  1. unknown - addons/darkrpmodification-master/lua/darkrp_customthings/jobs.lua:0

TEAM_BUILD = DarkRP.createJob("Builder", {
	color = Color(255, 255, 255, 255),
 	model = "models/player/Group01/Male_03.mdl",
	description = [[You build things for people.]],
	weapons = {"weapon_gphone", "weapon_fist"},
	command = "builder",
	max = 4,
	salary = 50,
	admin = 0,
	vote = false,
	hasLicense = false,
})

That code looks fine to me… are you sure it’s that job that’s erroring? Try removing the last comma (I don’t think it matters, but hey neatness.)

Post your whole job file. That job isn’t the thing causing the error.