I lost all my weapons

hey

why do i suddenly lost all my weapon?

Might want to give a better description of the problem.
You stopped spawning with weapons?

I have this problem as well. I had to download all the weapons as entities.

I just went on, and i had no weapons. I assumed it was part of an update, so i didnt do anything.

Load up gmod, and before starting singleplayer, type in console: gmod_weapons 1

all right ill try :smiley:

[editline]09:39AM[/editline]

still wont work :frowning:

[editline]09:40AM[/editline]

still wont work :frowning:

[editline]09:41AM[/editline]

still wont work :frowning:

Try it while you’re in singleplayer

i already try it :frowning:

Got the same problem…Is it really an update or what? Just to know WHY!

I think the command is “sbox_weapons 1”

will try. BTW, scopes dont work too, i mean there is no zoom. any ideas here?

If you didn’t spawn with your physgun, then you’ll need to enter a console command that will re-arm you.

As for the console command itself, I’ll have to look it up.

I spawn WITH physgun, camera and toolgun, no more no less…Stupid updates :wink:

Then it’s probably a Game-mode setting. Check your “Multiplayer” settings. They also effect single player. If “Spawn with Weapons” isn’t checked, then there’s your problem.

I have a fix. Go to developer console and type in sv_cheats 1 (must be in SP). Then type in impulse 101 and u should get all weps. If u are an absolute anti-cheat gamer then tooooo bad :wink:

sbox_weapons 1/0 - Toggles if you spawn with extra weapons. [1 = On; 0=Off] (Note you need to type kill in the console to see a change in this)

One more thing. Don’t blame the update unless you can prove that it’s causing the problem. In this case for me, my multiplayer settings persisted between games, including single player.

1 Problem at a time please…

@OP: that really doesnt describe the problem. 1) sbox_weapons 1 | 2) is this client side?

@Scope problem: This will be fixed in next update.

We get a thread like this every day
People need to learn to use :google: