I must be retarded...

Ok so when i go to extract files and stuff, i do what the notes say and extract to ‘garrysmod\addoons’ (with all the previous stuff) And it succesfuly extracts, but when i open up garrys mod it isnt there, along with my dozens of other downloaded mods. Anybody know a possible solution?

Make sure the addon has an info.txt file in. If not, look in the folders for an info.txt. Drag the folder containing the info.txt into addons.

Eg.

addons/roflcopter/screenshots/img1.jpf
addons/roflcopter/roflcopter/info.txt

In this case, move the second roflcopter folder into addons.

No like… Headspack.zip. I need help with stuff like that, SNPCs, NPCs, ect.

What do you mean? :S

make sure it is steam/steamapps/(your username)/garrysmod/garrysmod. not steam/steamapps/common/garrysmod/garrysmod, or something like that.

Wait…zip? Did you even unzip the folders before you put them into addons?

I’ve tried downloading headspack.zip like this, and it didn’t work for me either. I always assumed that it was a GMod 9 addon.

Right here a few problems and solutions;

  1. There is no Info.txt. Solutions (Now going to be under S) Either make one or extract it to its directorys

  2. There is an info.txt but it still doesn’t work. S. If there is an Info.txt it must be in the wrong place, make sure when you open the addon’s folder there is an info.txt not in an futher folder.

  3. What folder? All I see is a thing and I can’t open it. S. You haven’t extracted it yet, extract the file’s contents.

  4. I can’t extract anything. S You need someone like winzip, winrar or 7zip. Download one.

All I can think of really

Windows can unzip.

Windows can only unzip .zip extensions. Anything other than that you will need 3rd party software such as Winrar.

And Garrysmod.org only allows zip files.
I know what im talking about. Winrar, winzip, 7zip, tarballs.

Tarballs
lol
^^