I need help find model names

Hey, all!

I am currently working on a DarkRP server, and I’m doing the basic LUA stuff on my own. One thing I’m having trouble with is: When I attempt to make custom jobs, when it comes to the


model = {""}

bit, I don’t know how to find the model name of a player model that I downloaded from the workshop.

This is probably a really simple question, but I am very new to the whole DarkRP modification thing.
Thanks in advance for any help!

use a extractor

Thanks, I’ll look more into.
You don’t have to answer, but are there any you would recommend?

Find your model in the Q menu, you might need to search in the garrysmod and or steam folder. Once you find it, rightclick it and click Copy To Clipboard. Then just goto your code and paste to get the model location.

Also, please unbold your text, it looks awful the way it is.

You can scan the gma for the model in Lua. Just use file.Find, and where it says “MOD”, or “LUA” etc, just use the name of the addon and you can browse the contents.

Or you can just open the spawnmenu and find the model there, you know, in the Browse > Addons.

I personally use Gmadconv, just drag and drop the workshop’s gma file.

http://forum.facepunch.com/showthread.php?t=1173875

Oh right, it’s a DarkRP question… I thought he was making a game-mode or an addon… Little tired :frowning:

http://forum.facepunch.com/showthread.php?t=1249475

It doesn’t matter which gamemode, load sandbox and search the models.

[editline]25th February 2014[/editline]

You can do this with gmad.exe too, here’s handy .bat script:


"C:\Program Files (x86)\Steam\steamapps\common\GarrysMod\bin\gmad.exe" extract -file %1

I copied the models, but this is what I get: nypd1940_1

Meanwhile, all the default models look like this: models/player/Group01/Female_01.mdl

If you are a real pro, go download the GCFScape v1.8.5 Full from NEM and open up
C:\Program Files (x86)\Steam\SteamApps\common\GarrysMod\garrysmod\garrysmod_dir then find models, and then player folder, find the model you want (by name ofc) and open it’s propertis and copy the dir. Thats how i’ve done it alot.

Note: Only use the files that end with .mdl…

That only works with models that come with garry’s mod, which isnt the case for this thread.

[editline]26th February 2014[/editline]

Thats perfectly fine. Just put that inside the “” and add a .mdl to the model’s name

Actually it needs to be “models/nypd1940_1.mdl” as all models must be in the models directory
(I find it funny that some functions require you remove the directory name and some need it)

Whoops, my bad!

Nothing works. I can become the job, but I’m just “nothing.” I’ve tried every possible combination.
Edit:
Fixed it. It was a bug in the core darkrp files (I guess I was messing around with them before I found out about DarkRP modification addon and forgot).
Moving back to solved, thanks guys.
[This post can be deleted by a staff]