I need help with making a FastDL

Hi, I’m not new to making a Garry’s Mod server but when it comes down to making a FastDL and making it actually work, it can be a big issue.
I recently got into NFOservers and I’m loving it and the free FastDL system that comes with it.

The system works where you put the files in your server and when you’re at control panel you go to websync and hit sync files and it takes all
new vtf, mdl, wavs etc… and puts them in this web server that they give you and then they modify your server.cfg file and link it to your
web servers directory with the files and then when you restart it, it’s supposed to download the models to the client. Now the first time I tried it,
they didn’t download so I learned to make a resource.lua file in the lua/autorun/server directory and I used the resource.AddSingleFile( “” ) method
but that’s not working either. I used a resource file maker and it made the lines with the certain models and stuff perfect but still not downloading
anything to my clients.

I really wish I could take use of the function but it’s not going anywhere, I guess I might have to abandon my FastDL dreams and stick with workshop
to host. Please help and I’ll gladly offer you a cookie in return!

  1. Make sure the files are in .bz2 format.
  2. Don’t use resource.AddSingleFile. Use resource.AddFile

Yeah, I forgot that the server makes it in .bz2, I’ll try that and see how it goes.

[editline]20th January 2014[/editline]

I noticed that my FastDL server sync option also includes the original files as well as the .bz2 ones, does this mean I need to include the original version of the file and the .bz2 version or just .bz2?

I suggest WorkShop.

Workshop doesn’t work, people still join with errors.

For me it works fine.

You can have both files on there if you’d like. Just saying, in your resource.lua, your files don’t have to end with .bz2. Just on your FastDL server.

They might have made their game refuse to download any custom content.

If you are using workshop ( collection ) to put on addons on your server, REMEMBER that the client won’t download the content.

You need to make a folder in lua/autorun, and tell it to download the addon.

He already said he wants to use FastDL. Stop trying to force him to use workshop.

I did that lame method and people still get errors. Sure it downloads after making a resource.AddWorkshop but still doesn’t show the models…

You didn’t set it up correctly, but if you have FastDL, there really is no point.

Dude, I set it up right for sure, I made a resources.lua file in lua/autorun/server and it had on each line resource.AddWorkshop( “ID” ) and people would join, it’d download everything I listed but when they came through there was still errors, and yes I had my workshop collection for the server listed… Also these addons were over 64mb so those addons do not download to the client correctly.

Did you also host the workshop addons on your server using +host_workshop_collection?

That’s what I said and the server manager for nfo servers does it for me.

Why would you trust a server manager with such a simple task? Just do it yourself.

Ugh… All these FastDL threads. Can people start learn to search the forums first, please!

Alright. First, scrap Workshop. Since you have a FastDL you should take advantage of it. And if you want I can state a few billion reasons why you should use FastDL over WorkshopDL.

First of all, decide where on your web-server you want to place the FastDL. Just go with something like http://mysite.com/fastdl. After that, get this bzip2 compresser (Originally from srcds.com) that I have modified a little to enable recursive compression: bzip2.
Get the files you want to compress. Let’s say you want to compress a few maps located in the maps folder. Copy the maps folder INTO the compress folder of the zip you just downloaded, run bzip.bat and NOT the bzip2.exe as it does nothing without the cmd params the batch file feeds it with.
Upload the maps folder in the compress folder to your FastDL so it looks like this: http://mysite.com/fastdl/maps (Inside that folder, there should now be a couple of .bz2 files which is your compressed files.

Alright, let’s say you want to add a bunch of models to your Pointshop;

  1. Subscribe to the model you want for your Steam account on the Workshop. NOT the collection on your server.
  2. Get GMAD Extractor GUI.
  3. Extract the newly subbed model. (You might have to start up GMod once for it to download)
  4. Get Fox-Warrior’s Resources Generator.
  5. Open up Fox-Warrior’s Resources Generator and select the directory you just extracted with GMAD Extractor. Click on File->Generate Lua File->resource.AddFile->File and call the file anything you want, pref resources.lua and save it in lua/autorun of the directory you extracted with GMAD Extractor.
  6. Upload the entire extracted folder to your server’s /addons folder.
  7. Copy the models, materials and sound (If there are any) into the compress folder of bzip once again. Run bzip.bat.
  8. Upload the folders in the compress folder to your FastDL (http://mysite.com/fastdl should now have a dir structure of http://mysite.com/fastdl/models etc etc).
  9. Put this into server.cfg:


sv_downloadurl "http://mysite.com/fastdl"
sv_allowdownload 0
sv_allowupload 0 // Security measure.


  1. Add the model to your pointshop code ( Google! =] ).
  2. Restart server and watch dem files download.

Note1: You don’t EVER want .lua files on your FastDL.
Note2: This is very simple, everyone with a brain should be able to do it. If the case is that your brain is currently under maintenance, malfunctioning or is on a vacation, I’ll create a video for you.
Note3: If you by any chance don’t understand the video. I will recreate it and speak english with a russian combined with alien accent and that way I might make myself clearer.

Dude, it’s a managed server, I can not touch the command line so the freakin’ manager does it for me!

[editline]23rd January 2014[/editline]

And I’ve done all this before and still nothing downloaded. The only time I got it to work was were I would timeout when I joined and when I removed the resource file I could join, same with my friends.

The only time I got it to work was by removing all my addons and then I noticed it worked. The problem is, THERE’S NO ADDONS and when I put them back, same shiz happened. I think it may be a collision with other resource files from addons I have. Maybe, maybe not.

Would you like me to initiate Operation NoBrainAlien?

You don’t need to, all I’m saying is that I’ve done this and nothing works.