I need some help with my maps.

Now, I posted a previous thread like this before, but no one had valid answers. I’ll quote myself and specs.

Okay so, I’ve been playing Gmod recently and it’s been working fine. But then when I started it up, instead of that awesome background you’re started with it turned black. I said to myself “Ah well.” But the game worked fine. Until recently. Now when I try to play GM-Construct like, all the ground is black and screwed up. It’s real weird. The sky is black too, and when I pause I don’t see any menu buttons.

Anyone know what’s wrong?

Operating System: Windows XP Home Edition (5.1, Build 2600) Service Pack 3 (2600.xpsp_sp3_gdr.100216-1514)
Language: English (Regional Setting: English)
System Manufacturer: Dell Inc.
System Model: Vostro 200
BIOS: Phoenix - AwardBIOS v6.00PG
Processor: Intel® Pentium® Dual CPU E2140 @ 1.60GHz (2 CPUs)
Memory: 1014MB RAM
Page File: 558MB used, 1882MB available
Windows Dir: C:\WINDOWS
DirectX Version: DirectX 9.0c (4.09.0000.0904)
DX Setup Parameters: Not found
DxDiag Version: 5.03.2600.5512 32bit Unicode


It happens now with any map that isn’t flatgrass, I have CS:S, Portal, and TF2. Not having HL2 isn’t the problem since it worked during the first few weeks, but now it’s stopped. Also when I pause all the choices are invisble, including the box choices. I’m going to try to delete all the lua and other downloaded things like that. Any help would be greatly appreciated.

EDIT: Also, where can I find all the files Gmod downloaded from Multi-player servers? I want to see if those messed up my files by deleting them.

Sorry, but I don’t see your graphics card specs listed. Given what you’ve described, it’s a likely suspect. What are they?

Ah, but more mundane things first: Have you tried verifying your game cache/ reinstalling?

Hmm, during this decline in graphics, did you change anything? settings, new addons etc?
Which graphics card do you run with because it sound a bit like a gfx card dying right there, have you had artifacts like that in any other game?

I believe it’s Intel® GMA 3100, but like I said, it was working fine when I first got it. I may clean the entire Gmod if I don’t get a answer soon.

[editline]07:03PM[/editline]

Well, my addons are Kermites Pistol pack, Mad Cows weapon pack (Without the DoD) and Ninja sword pack. I also have PHX with SVN, but that’s all. I never tampered with anything else.

If I need a new card that’s no problem as I may be getting a new computer soon, but if I must upgrade this one what’d you suggest.

Ah, you’re using integrated graphics. I fear they cannot really support Source games, or many others- and you are potentially damaging it by trying- unfortunately, the only real solution is to upgrade.

Thank you very much, what graphics card would you suggest I buy?

yaah on-board is a no go, i suggested this http://www.buy.com/prod/xfx-hd-455x-yaf2-radeon-hd-4550-graphics-card-pci-express-2-0-x16-512/q/loc/101/213903345.html to a guy earlier, it’s a Radeon 4550 HD, it should run source games fine and it costs 50 bucks

Are you on a laptop, or a desktop computer?

woops, beaten to the punch.

Desktop of course.

[editline]07:11PM[/editline]

My other choice if I don’t get a new computer is to get this one upgraded, but the person at the computer store said it was around 25$, so thank you for that but I was wondering if there was a bit cheaper one.

personally i’m running on a card that costs about 160 bucks, and thats even a couple of year old, so 25$ or 50$ is quite cheap, personally i doubth that a 25$ card can run source properly but i might be wrong

Alright. Thank you all for your help!

Hope it works out :slight_smile: