If it's not File Mismatch it's Cannot load asses bundles - Please help.

I’ve gone through majority of the steps people have suggested. I’ve uninstalled the game, reinstalled. Opted in for the dev in the latest version, I’ve re-installed eac and uninstalled eac. I even went and removed every file that relates to rust and I STILL cannot access this game that I payed for, what gives? Does this happen every update?

None of these have worked to FIX the game, all of them helped enough so I can play but what’s the point if I can’t actually access it through steam!?

When you launch the game and you are presented with the launcher, what are your settings?
Also, what are your specs? If you’re using an Nvidia GPU I may have fixes that can help.

[editline]17th May 2015[/editline]

[editline]17th May 2015[/editline]

Is my specs from the client.

Did you try verifying your files in Steam?

Yes I did, multiple times.

Still having an issue, is there any developers reading this that may be able to shed some light please?

if i get the cannot load assets error i just try restarting the game right away and it works the second time without fail

It’s not working for me sadly, it’s touch and go. Sometimes I’m able to load it up, sometimes I’m not able to. I’m pretty sure it’s a problem with EAC rather than rust itself.

[editline]17th May 2015[/editline]

I was playing for a good 3-4 hours previously, through steam actually. I had to close it because it bugged out, went to load it again within a minute and I’m locked out again.

its an eac issue. nothing you can do currently will fix it.

Then what does that mean? A whole playerbase has to suffer?

Registered just to post, I have this issue and both a reinstall of EAC, Steam and Rust itself has not rendered any solution.

Have not seen any dev from facepunch/eac acknowledge this yet. Disappointing.

Still not working guys and EAC links us to here, can any developer shed some light on this problem?

Here’s what I’m assuming is happening:

  1. Your antivirus or firewall is blocking certain files from reading.
  2. A recent Rust update must’ve caused this bug (a is usual with updates, they always seem to break something).

Also try to understand that the developers are literally working around the clock to make another update every week for Rust, and although they may not respond to every single thread, I’m 100% sure they’ll fix your issues.
Also note that Rust in in Early Access, as in it’s barely in a playable state, let alone past the Alpha of production. Not everything is going to work, and not everything will be fixed immediately.

Stop with the EA patronizing shit. rust is quite playable.

Eac is independent of rust.

come on … try everything …
uninstall rust, reinstall rust
quit steam, launch steam VIA ADMINISTRATOR PRIVILEGES
try a manual install of EAC

… we’ve all had our share of problems launching rust, and most of us managed to find a way to fix it

for me part i just had to launch steam with ADMINISTRATOR PRIVILEGES (right click on steam and launch via administrator privileges)

None of this works. Try reading the other 6000 threads

Sorry about this happening to you. Please wait for an update within the next few hours. I will let you know when it is live.

Sorry for the delay. Could you check now if the problem is resolved for you? Thanks!

Nope, same issue.