Ignite, blood, and flashlight problems.

When I use the ignite tool I hear the fire, but I don’t see the fire. When I turn on the flashlight, it’s very small. And the blood appears as red cubes. How do I fix these problems?

Perhaps you do not have some textures?

This happens when source runs on an intel gpu. Any graphics card that has pixel shader can do particle effects. If you have a nvidia or ati gpu that supports pixel shader, put -dxlevel 81 in your launch options.

This guy sort of has the general idea but he still doesn’t know that much.

What are your specs?

How do I do that. Sorry, I’m sort of new to gmod.


Also, I can definetly tell you that my graphics card can do particle effects, because in Counter Strike source and Zombie Master, and Zombie panic, fire shows up. My graphics card is an ATI Radeon Xpress 200, and can play games with decent quality graphics, like The Movies, very smoothly.

Yeah that’s a pretty terrible card. Try running it in forced DX8 mode like Ellekay said.

Right click Garry’s Mod in your Steam games list > Properties > Set launch options > -dxlevel 81

Also, your flashlight will always appear weak because you cannot do dynamic shadows.

But when I first got Gmod the flashlight was fine. And so was the blood. I did set it to -dxlevel 71 which could have been the cause.

Hm, that is odd. Is it still running in DX7 by any chance? If so, we’ve found your problem. (Look under Video Settings in-game, it should show you what version it’s running.)

My laptop has a 32mb intel intgrated GPU, My desktop has an over-clocked nVidia 6150SE.

The laptop BSOD’s on gm_construct, Runs flatgrass on high settings DX9. It also takes a long time to spawn props. The hud also gets fucked up when stuff goes over it. My nVidia desktop runs it all perfectly.

Fire does not work on Intel GPUs, and blood is a wireframe. Usually models are glossy white. Vorts have pink and black eyes. Anti-aliasing does not work. Doing anything to change the settings BSODs. The BSOD is a buffer overflow in the ram or gpu.

Same with mine.

I have a laptop with integrated graphics that can run Garry’s Mod on all medium with no problems. Not all Intel GPUs shit themselves when they try and run games.

My laptop is old too. Made in 2004. 512mb of ram. It’s really messed up too see it in gmod. Only the viewmodels light up with the flashlight too. Half-Life 2:DM runs great though, just no flashlight and bloom. HL2:DM also runs on the 2004-2005 version of source, too.

Where were we going with this conversation?

I’m gonna run gmo in 10 mins and see if anything has changed.

hey help me with my problem a fire in the floor\world, I can hear it but i can’t see it too…
And my flashlight doesn’t work when i press f!

ya i have the same problem as OP, i set it to force 8.1 and nothing changed i have a HP zv5000 with upgraded RAM and Hard drive

Guys i solved mine, mine iss a lua problem i cleaned up my lua and then it worked!